diff options
author | Peter Mattern | 2022-04-27 14:19:10 +0200 |
---|---|---|
committer | Peter Mattern | 2022-04-27 14:19:10 +0200 |
commit | c44db99b8cdb15bf436d1f2d027c2fce35a7d17b (patch) | |
tree | 3955276360be0cce942694319c80bfe8de451693 /PKGBUILD | |
parent | 34f51e0fe1e71da33fa2407b7c8e8f8c422b0752 (diff) | |
download | aur-c44db99b8cdb15bf436d1f2d027c2fce35a7d17b.tar.gz |
Replace qmake with cmake
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 10 |
1 files changed, 5 insertions, 5 deletions
@@ -6,14 +6,14 @@ pkgver=0.10.0.2.gac3e510 pkgrel=1 pkgdesc='Lightweight Qt5 plain text editor for Linux' arch=('i686' 'x86_64') -url='https://github.com/tsujan/FeatherPad' +url='https://github.com/tsujan/featherpad' license=('GPL3') depends=('qt5-svg' 'qt5-x11extras' 'hunspell' 'desktop-file-utils' 'gtk-update-icon-cache') -makedepends=('git' 'qt5-tools') +makedepends=('git' 'cmake' 'qt5-tools') optdepends=('qt5-translations: localized keyboard shortcuts') provides=("$_pkgname") conflicts=("$_pkgname") -source=("$_pkgname::git+https://github.com/tsujan/FeatherPad.git") +source=("git+${url}.git") sha256sums=("SKIP") pkgver() { @@ -24,11 +24,11 @@ pkgver() { build() { rm -Rf build && mkdir build cd build - qmake $srcdir/$_pkgname/ CONFIG+=debug + cmake $srcdir/$_pkgname/ make } package() { cd build - make INSTALL_ROOT=$pkgdir install + make DESTDIR="${pkgdir}" install } |