summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatheus2020-04-14 17:59:49 -0300
committerMatheus2020-04-14 17:59:49 -0300
commit70db724f42e8658596eaa8f9f3f1f090343a9cb3 (patch)
tree2aa4890b52d263db955f497b1ccbb9e87b7e569e /PKGBUILD
parentd2ac92236ca2af564a9117526d65d79b909948a1 (diff)
downloadaur-70db724f42e8658596eaa8f9f3f1f090343a9cb3.tar.gz
75.0-3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e396511966e..c6155239dbad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
pkgname=fedora-firefox-wayland-bin
pkgver=75.0
-pkgrel=2
+pkgrel=3
# fedora version
fc="fc32"
pkgdesc="Fedora's firefox build with wayland enabled by default"
arch=(x86_64)
license=(MPL GPL LGPL)
url="https://www.mozilla.org/firefox/"
-provides=('firefox')
-conflicts=('firefox')
+provides=('firefox' 'libffi=3.1')
+conflicts=('firefox' 'libffi=3.1')
options=(!emptydirs !strip)
depends=(gtk3 mozilla-common libxt startup-notification mime-types dbus-glib
ffmpeg nss hunspell-en_US sqlite ttf-font libpulse libvpx icu libjpeg6-turbo pipewire)
@@ -20,9 +20,11 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
'pulseaudio: Audio support'
'speech-dispatcher: Text-to-Speech')
-source=("https://kojipkgs.fedoraproject.org//packages/firefox/$pkgver/1.$fc/x86_64/firefox-$pkgver-1.$fc.x86_64.rpm")
+source=("https://kojipkgs.fedoraproject.org//packages/firefox/$pkgver/1.$fc/x86_64/firefox-$pkgver-1.$fc.x86_64.rpm"
+ "https://download-ib01.fedoraproject.org/pub/fedora/linux/development/32/Everything/x86_64/os/Packages/l/libffi-3.1-24.fc32.x86_64.rpm")
-sha256sums=('2021838e67bf96dad3f2dce24a8baace217b72a976d6f949c51dbea847e0e27b')
+sha256sums=('2021838e67bf96dad3f2dce24a8baace217b72a976d6f949c51dbea847e0e27b'
+ '86c87a4169bdf75c6d3a2f11d3a7e20b6364b2db97c74bc7eb62b1b22bc54401')
prepare() {
# remove a bit of fedora's custom sutff
@@ -41,4 +43,3 @@ package() {
mv usr/lib64 usr/lib
cp -r usr/ $pkgdir/
}
-