summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilip Goto2020-11-20 14:41:21 +0100
committerPhilip Goto2020-11-20 14:41:21 +0100
commit4c041a51b49ca4198e6df227b83f89b2171a4917 (patch)
tree7cb7da8e7601ed408fbfd597f82c994fcd1340f8 /PKGBUILD
parent1c4aa45379d502476bba29bf5931c4464a9153c2 (diff)
downloadaur-4c041a51b49ca4198e6df227b83f89b2171a4917.tar.gz
Update to newest release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f73d50dc1160..35416b4f1cc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Sam Whited <sam@samwhited.com>
pkgname=feedbackd
-pkgver=0.0.0+git20200726
+pkgver=0.0.0+git20201114
pkgrel=1
pkgdesc="A daemon to provide haptic feedback on events"
url="https://source.puri.sm/Librem5/feedbackd"
license=(GPL3 LGPL3)
-arch=(i686 x86_64 armv6h armv7h aarch64)
+arch=(i686 x86_64 armv7h aarch64)
depends=(dconf
gsound
json-glib
@@ -18,19 +18,18 @@ makedepends=(gobject-introspection
provides=(libfeedback
purism-feedbackd
purism-libfeedback)
-source=("https://source.puri.sm/Librem5/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
-sha256sums=('e9632d1d1ef228bb7f6ca3d3d875806b2a5763b4def4e30e94acf0c7f3eb79ef')
+source=("${url}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
+sha256sums=('e5da62d70906a9d92cdcfe7d04fe7d3131a4475a9b39599f27ac2da89b15de59')
build() {
- rm -rf build
- arch-meson "${pkgname}-v${pkgver}" build -Dexamples=false -Dgtk_doc=true
- ninja -C build
+ arch-meson "${pkgname}-v${pkgver}" build -Dexamples=false -Dgtk_doc=true
+ meson compile -C build
}
check() {
- ninja -C build test
+ meson test -C build --print-errorlogs
}
package() {
- DESTDIR="${pkgdir}" ninja -C build install
+ DESTDIR="${pkgdir}" meson install -C build
}