summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorstarsareintherose2021-11-30 11:08:56 +0000
committerstarsareintherose2021-11-30 11:08:56 +0000
commit35949cb19e7513168c03034b2d1076b49cea0728 (patch)
treeefa2dbcb4238314ab48b0b71c2ce1e11e84d07c7 /PKGBUILD
parentb07e9703ac351efcacc4776776419fc92298cfa8 (diff)
downloadaur-35949cb19e7513168c03034b2d1076b49cea0728.tar.gz
update depen
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a2ff45c9736..d33126d01fbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,13 @@ pkgdesc='A nice place to read on the web'
arch=('x86_64')
url='https://feedbin.com/'
license=('MIT')
-provides=('feedbin')
-conflicts=('feedbin')
-depends=('ruby2.6' 'ruby2.6-bundler' 'postgresql' 'redis' 'memcached' 'elasticsearch')
+depends=('ruby2.6' 'ruby2.6-bundler' 'postgresql-10' 'redis' 'memcached' 'elasticsearch2')
+optdepends=('apache: Web server'
+ 'nginx: Web server')
makedepends=('git')
-source=("git+https://github.com/feedbin/feedbin.git")
-sha256sums=('SKIP')
-
+source=("git+https://github.com/feedbin/feedbin.git" ".env.example")
+sha256sums=('SKIP'
+ '6b9f11017502441951c8586d4ff845f3fe0aa30340c585a9a03334f42c239e98')
build() {
cd $srcdir/$_pkgname
sudo bundle-2.6
@@ -21,6 +21,7 @@ build() {
package() {
mkdir -p $pkgdir/usr/share/webapps/$_pkgname
+ install -Dm 755 .env.example $pkgdir/usr/share/webapps/$_pkgname/.env.example
cp -r $srcdir/$_pkgname/* $pkgdir/usr/share/webapps/$_pkgname
}