summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2020-02-08 13:27:56 +0100
committerMichel Zou2020-02-08 13:27:56 +0100
commite7d7caa7b823926d4771058ee67ea143cd9b10a7 (patch)
tree7b7a9e2fbc888e762b815425efe5fcfa8da3170d /PKGBUILD
parentc708ec6763c76415b498478b296b1ae0c5aaf6bb (diff)
downloadaur-e7d7caa7b823926d4771058ee67ea143cd9b10a7.tar.gz
petsc
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a18b90f41e8b..865e69144d49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,9 @@ prepare() {
cd ${pkgname}-${pkgver}
git submodule init
git submodule update -f --init
- curl -L https://github.com/feelpp/feelpp/pull/1415/commits/8b29331f5b2a4c6f47631b788829d5529eaf2d17.patch | patch -p1
+
+ # https://github.com/feelpp/feelpp/pull/1415
+ git cherry-pick 8b29331f5b2a4c6f47631b788829d5529eaf2d17
}
build() {
@@ -37,8 +39,8 @@ build() {
-DFEELPP_ENABLE_PYFEELPP_LIBFEELPP=OFF \
-DFEELPP_ENABLE_DOCUMENTATION=OFF \
-DFEELPP_ENABLE_GMSH=ON \
- -DFEELPP_ENABLE_PETSC=ON \
- -DFEELPP_ENABLE_SLEPC=ON \
+ -DFEELPP_ENABLE_PETSC=OFF \
+ -DFEELPP_ENABLE_SLEPC=OFF \
-DFEELPP_ENABLE_ANN=ON \
-DFEELPP_ENABLE_FFTW=ON \
-DFEELPP_ENABLE_GSL=ON \
@@ -50,6 +52,6 @@ build() {
package() {
cd ${pkgname}-${pkgver}/build
make DESTDIR="$pkgdir" install
-# rm "$pkgdir"/usr/bin/{gflags_completions.sh,ginsh}
+ rm "$pkgdir"/usr/bin/ginsh
}