summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsolarbaron2024-05-27 19:43:58 +0200
committersolarbaron2024-05-27 19:43:58 +0200
commitfcd90469a56a8ab0361555f1d383ec5f5082c188 (patch)
tree9f8f90df0af090485592745fae78943690ad681e /PKGBUILD
parentf9eb35d114b16955bfa3f7d9c13bea2aa20cbdd8 (diff)
downloadaur-fcd90469a56a8ab0361555f1d383ec5f5082c188.tar.gz
Fixed build problems
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 49587e5a5319..1ac500385c6b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Contributor: solarbaron
pkgname=feishin-git
-pkgver=v0.7.1.r3.g168153b
+pkgver=v0.7.1.r9.gaa89c5e
pkgdesc='Modern music player with support for navidrome servers.'
pkgrel=1
arch=('x86_64' 'aarch64')
license=('GPL3')
-depends=('mpv')
-makedepends=('yarn' 'npm')
+optdepends=('mpv: Alternative audio backend')
+makedepends=('npm')
url='https://github.com/jeffvli/feishin'
provides=("${pkgname%-git}")
conflicts=("feishin" "feishin-bin")
@@ -23,8 +23,8 @@ pkgver() {
build() {
cd $pkgname
- yarn install --frozen-lockfile
- yarn package
+ npm install --force
+ npm run package
}
package() {