summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph2019-09-06 16:30:48 +0200
committerChristoph2019-09-06 16:30:48 +0200
commit3d14b97ae84a99582c0060cf52ff612291b31c8b (patch)
tree4eb0f1505b198b463cab34b6864c094668788150 /PKGBUILD
parentd164bf7b273dc103beb05cfdd369e856b43372b6 (diff)
downloadaur-3d14b97ae84a99582c0060cf52ff612291b31c8b.tar.gz
pkbulid cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a18a6ff1f597..a3e1a8ab61d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,6 +37,14 @@ prepare() {
# Adjust the electron version to use when building
electron_version="`expac %v electron4 | cut -d'-' -f1`"
sed -i "s|\(\s\+\"electron4\":\).*,|\1 \"$electron_version\",|" package.json
+
+ # Adjust node-sass version to avoid build issues
+ npm install "node-sass@4.12.0"
+
+ # Prepare the packages for building
+ npm install lerna
+ lerna bootstrap
+
}
build() {
@@ -46,8 +54,6 @@ build() {
export npm_config_cache="$srcdir"/npm_cache
export PATH="$srcdir/ferdi/node_modules/.bin:$srcdir/python2_path:$PATH"
- npm install lerna
- lerna bootstrap
gulp build
electron-builder --linux dir
}