summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSky Aw2020-08-02 22:32:42 +0800
committerSky Aw2020-08-02 22:32:42 +0800
commit36c7142b33cef5074eed58ee4437a3a2b1a89a8b (patch)
treeeb8adca1e22ab84c2158e09f0a8ffdd79516e840 /PKGBUILD
downloadaur-36c7142b33cef5074eed58ee4437a3a2b1a89a8b.tar.gz
Placed .SRCINFO and PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56dda555b030
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Sky Aw <sky100aw@gmail.com>
+
+pkgname=fetchpac-git
+pkgver=1.0.r2.gc99a9ef
+pkgrel=1
+pkgdesc="A CLI tool written in Bash for printing system package information."
+arch=('any')
+url="https://github.com/sky-aw/fetchpac"
+license=('GPL')
+depends=('bash')
+makedepends=('git')
+source=("$pkgname::git+https://github.com/sky-aw/fetchpac.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ # cutting off 'v' prefix that presents in the git tag
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+}