summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcbpark2017-04-14 16:27:09 +0900
committercbpark2017-04-14 16:27:09 +0900
commitad5f6443d995a289d52427829abd8ca6266a98e5 (patch)
tree08cbbfe67d36fb98601a35eb7f114e95483269dd /PKGBUILD
parent3b90cb6cb5b429a618730460af11808873d61d63 (diff)
downloadaur-ad5f6443d995a289d52427829abd8ca6266a98e5.tar.gz
upgpkg: feynhiggs 2.13.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce3487c9f1ef..7b03b2f89783 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=FeynHiggs
pkgname=feynhiggs
-pkgver=2.12.0
+pkgver=2.13.0
pkgrel=1
pkgdesc="FeynHiggs is a Fortran code for the (diagrammatic) calculation of the masses, mixings and much more of the Higgs bosons in the MSSM with real/complex parameters at the highest level of accuracy."
arch=("i686" "x86_64")
@@ -10,18 +10,26 @@ url="http://wwwth.mpp.mpg.de/members/heinemey/feynhiggs/cFeynHiggs.html"
license=('GPL3')
depends=("gcc-fortran")
options=('staticlibs')
-source=("http://wwwth.mpp.mpg.de/members/heinemey/feynhiggs/newversion/${_pkgname}-$pkgver.tar.gz")
-sha256sums=('513e8860c3f33220b5468f4d65d328c9c33dce75fb46adfbc5bca1218eefe706')
+source=("http://wwwth.mpp.mpg.de/members/heinemey/feynhiggs/newversion/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('ecf839bb16d44ce8b6b6f6b9934f26733a3fc616861d17ec20a68241a6286936')
+
+prepare() {
+ cd "${_pkgname}-$pkgver"
+
+ sed -i 's/LIBDIR = $(PREFIX)\/lib$(LIBDIRSUFFIX)/LIBDIR = $(PREFIX)\/lib/' \
+ makefile.in
+}
build() {
cd "${_pkgname}-$pkgver"
+
./configure --prefix=/usr --enable-full-g-2 --enable-slhapara
- sed -i 's/LIBDIR = $(PREFIX)\/lib$(LIBDIRSUFFIX)/LIBDIR = $(PREFIX)\/lib/' makefile
- make
+ make ${MAKEFLAGS}
}
package() {
cd "${_pkgname}-$pkgver"
+
make PREFIX="$pkgdir/usr" install
install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
cd $pkgdir/usr/bin; mv fcc fcc-feynhiggs; mv table table-feynhiggs