summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlolilolicon2015-09-03 02:04:35 +0800
committerlolilolicon2015-09-03 02:04:35 +0800
commit25b8d17a55c2fe65de3782ae176ca2b9368c45f8 (patch)
tree2f8cd5e94c2cdaed1a2d6fd70413ce54866bfd9b /PKGBUILD
downloadaur-25b8d17a55c2fe65de3782ae176ca2b9368c45f8.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e825bea31dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: lolilolicon <lolilolicon@gmail.com>
+
+_name=FFcast
+_ver=2.4.1
+pkgname=ffcast
+epoch=1
+pkgver=${_ver//-/}
+pkgrel=1
+pkgdesc="FFcast has almost nothing to do with FFmpeg or screencast ;)"
+arch=(any)
+url="https://github.com/lolilolicon/FFcast"
+license=(GPL3)
+depends=('bash>=4.3' ffmpeg xorg-xdpyinfo xorg-xprop xorg-xwininfo xrectsel)
+makedepends=(autoconf automake perl)
+source=("https://github.com/lolilolicon/$_name/archive/$_ver.tar.gz")
+md5sums=('ba43b7b6ef347b023fd3efa59f5b0429')
+
+prepare() {
+ cd "$_name-$_ver"
+ ./bootstrap
+}
+
+build() {
+ cd "$_name-$_ver"
+ ./configure --prefix /usr --libexecdir /usr/lib --sysconfdir /etc \
+ --disable-xrectsel
+ make
+}
+
+package() {
+ cd "$_name-$_ver"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:st=2:sw=2:et: