summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornathanielcwm2020-04-22 13:03:37 +0800
committernathanielcwm2020-04-22 13:03:37 +0800
commitbb6e21810089c61f06436a0aa9219296c1029d8a (patch)
tree23606811585588e239a86c70729c49ab57497fb9 /PKGBUILD
parentc309ec3be306a284445262c998ff2f94e0a03d09 (diff)
downloadaur-bb6e21810089c61f06436a0aa9219296c1029d8a.tar.gz
fix build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 72942b146b4c..8a4e35ef5a89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
# Contributor: Bruno Filipe < gmail-com: bmilreu >
_svt_hevc_ver='1.4.3'
-_svt_av1_ver='0.8.1'
+_svt_av1_ver='0.8.2'
_svt_vp9_ver='0.1.0'
pkgname=ffmpeg-amd-full
pkgver=4.2.2
-pkgrel=1
+pkgrel=2
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features for AMD)'
arch=('x86_64')
url='https://www.ffmpeg.org/'
@@ -44,7 +44,7 @@ conflicts=('ffmpeg')
source=("https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"{,.asc}
"ffmpeg-full-add-svt-hevc-${_svt_hevc_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v${_svt_hevc_ver}/ffmpeg_plugin/0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch"
"ffmpeg-full-add-svt-hevc-docs-${_svt_hevc_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v${_svt_hevc_ver}/ffmpeg_plugin/0002-doc-Add-libsvt_hevc-encoder-docs.patch"
- "ffmpeg-full-add-svt-av1-${_svt_av1_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-AV1/v${_svt_av1_ver}/ffmpeg_plugin/0001-Add-ability-for-ffmpeg-to-run-svt-av1-with-svt-hevc.patch"
+ "ffmpeg-full-add-svt-av1-${_svt_av1_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-AV1/1fdb3c9952187736efc831257454677521157560/ffmpeg_plugin/0001-Add-ability-for-ffmpeg-to-run-svt-av1-with-svt-hevc.patch"
"ffmpeg-full-add-svt-vp9-${_svt_vp9_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/v${_svt_vp9_ver}/ffmpeg_plugin/0001-Add-ability-for-ffmpeg-to-run-svt-vp9-with-svt-hevc-av1.patch"
'ffmpeg-full-add-decklink-11.5-support.patch'::'https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/f32f9231dd4f74d9f95eef575b838bdc3e06a234'
'LICENSE')
@@ -52,7 +52,7 @@ sha256sums=('cb754255ab0ee2ea5f66f8850e1bd6ad5cac1cd855d0a2f4990fb8c668b0d29c'
'SKIP'
'878757eb6d7072521caaeb71f1453ec3fc0f91a12936ef302e1625184787c6a6'
'1499e419dda72b1604dc5e3959668f3843292ff56bfba78734e31510ba576de0'
- 'efbe348e0dad6b5f9fc501a34ff8304d82c2745ec9ac952e72f8549775c2fe78'
+ 'd371366ceda9233c1b9a60c680878f567861b675605a8dae5c275d633c51ba9f'
'7690a4f6bdc4a57e35c7ff5b6e87f2fe6d056d452eff9e767eaccff41832f4d7'
'd23dedb5a275d1d753d30fd544a46d5b609868ad5d384b9c8c2ecc1a02281828'
'04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')
@@ -60,6 +60,8 @@ validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
prepare() {
# add svt codec support for hevc, av1 and vp9
+ rm -f ffmpeg-${pkgver}/libavcodec/libsvt_{hevc,av1,vp9}.c
+ sed -i 's/eb_init_handle/svt_av1_enc_init_handle/' "ffmpeg-full-add-svt-vp9-${_svt_vp9_ver}.patch"
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/ffmpeg-full-add-svt-hevc-${_svt_hevc_ver}.patch"
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/ffmpeg-full-add-svt-hevc-docs-${_svt_hevc_ver}.patch"
patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/ffmpeg-full-add-svt-av1-${_svt_av1_ver}.patch"
@@ -77,7 +79,6 @@ build() {
./configure \
--prefix='/usr' \
--extra-cflags='-I/usr/include/tensorflow' \
- --extra-ldflags="$_ldflags" \
\
--disable-rpath \
--enable-gpl \
@@ -203,4 +204,4 @@ package() {
make -C "ffmpeg-${pkgver}" DESTDIR="$pkgdir" install
install -D -m755 "ffmpeg-${pkgver}/tools/qt-faststart" -t "${pkgdir}/usr/bin"
install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
-} \ No newline at end of file
+}