summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornathanielcwm2020-04-08 12:39:40 +0800
committernathanielcwm2020-04-08 12:39:40 +0800
commit2b05d534b59ace5cedf9851d18aa4988f3582940 (patch)
tree18037abb1fa7dea9d03df2e60f26582914aaefcd /PKGBUILD
parent41cc5fed92771c0153d878e0911ad88fd62143d0 (diff)
downloadaur-2b05d534b59ace5cedf9851d18aa4988f3582940.tar.gz
Revert "Remove Tensorflow Support"
This reverts commit 41cc5fed92771c0153d878e0911ad88fd62143d0.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1add773de0d6..45067af97392 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ depends=(
'glslang' 'libgme' 'gsm' 'libiec61883' 'libilbc' 'jack' 'kvazaar' 'lensfun'
'libmodplug' 'lame' 'opencore-amr' 'openjpeg2' 'opus' 'pulseaudio' 'librabbitmq-c'
'librsvg' 'rubberband' 'rtmpdump' 'snappy' 'libsoxr' 'speex' 'srt' 'libssh'
- 'svt-hevc' 'svt-av1' 'svt-vp9' 'tesseract' 'libtheora' 'twolame'
+ 'svt-hevc' 'svt-av1' 'svt-vp9' 'tensorflow' 'tesseract' 'libtheora' 'twolame'
'v4l-utils' 'vid.stab' 'vmaf' 'libvorbis' 'libvpx' 'wavpack' 'libwebp' 'x264'
'x265' 'libxcb' 'xvidcore' 'libxml2' 'zimg' 'zeromq' 'zvbi' 'lv2' 'lilv' 'xz'
'libmysofa' 'openal' 'ocl-icd' 'libgl' 'sndio' 'sdl2' 'vapoursynth'
@@ -46,7 +46,7 @@ makedepends=(
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavutil.so' 'libpostproc.so' 'libavresample.so' 'libswscale.so'
'libswresample.so' 'ffmpeg' 'ffmpeg-full' 'ffmpeg-git')
-conflicts=('ffmpeg' 'doxygen' 'svt-av1-git')
+conflicts=('ffmpeg' 'doxygen')
source=('git+https://git.ffmpeg.org/ffmpeg.git'
"ffmpeg-full-git-add-svt-hevc-${_svt_hevc_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v${_svt_hevc_ver}/ffmpeg_plugin/0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch"
"ffmpeg-full-git-add-svt-hevc-docs-${_svt_hevc_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v${_svt_hevc_ver}/ffmpeg_plugin/0002-doc-Add-libsvt_hevc-encoder-docs.patch"
@@ -91,6 +91,8 @@ build() {
./configure \
--prefix='/usr' \
+ --extra-cflags="-I/usr/include/tensorflow" \
+ --extra-ldflags="$_ldflags" \
\
--disable-rpath \
--enable-gpl \
@@ -163,6 +165,7 @@ build() {
--enable-libsvthevc \
--enable-libsvtav1 \
--enable-libsvtvp9 \
+ --enable-libtensorflow \
--enable-libtesseract \
--enable-libtheora \
--disable-libtls \