summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornathanielcwm2020-04-08 05:42:22 +0800
committernathanielcwm2020-04-08 05:42:22 +0800
commitee8c3834527201e23da177a38da0e633fafbf03c (patch)
treefecdf1665f45d0dc73cafdabe260d820d75cf387 /PKGBUILD
parent563266330075ab9d44a846175380a53dcd28d017 (diff)
downloadaur-ee8c3834527201e23da177a38da0e633fafbf03c.tar.gz
update codecs and stuff to truly be full
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD84
1 files changed, 60 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d7bf4067ff71..0053cddf90a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,35 +3,42 @@
# Contributor: Marko Korhonen <reekymarko at reekynet.com>
# Contributor: Bruno Filipe < gmail-com: bmilreu >
+_svt_hevc_ver='1.4.3'
+_svt_av1_ver='0.8.0'
+_svt_vp9_ver='0.1.0'
+
pkgname=ffmpeg-amd-full-git
_srcname=ffmpeg
pkgver=4.3.r97205.g3935c891e9
-pkgrel=1
+pkgrel=2
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features for AMD; git version)'
arch=('i686' 'x86_64')
url='https://www.ffmpeg.org/'
license=('custom: nonfree and unredistributable')
depends=(
# official repositories:
- 'glibc' 'alsa-lib' 'jack' 'libpng'
- 'bzip2' 'frei0r-plugins' 'libgcrypt' 'gmp' 'gnutls' 'ladspa' 'libass' 'aom'
- 'libbluray' 'libbs2b' 'libcaca' 'celt' 'libcdio-paranoia' 'libdc1394'
- 'libavc1394' 'libfdk-aac' 'fontconfig' 'freetype2' 'fribidi' 'libgme' 'gsm'
- 'libiec61883' 'lensfun' 'libmodplug' 'lame' 'opencore-amr' 'openjpeg2' 'opus'
- 'pulseaudio' 'librsvg' 'rubberband' 'rtmpdump' 'snappy' 'libsoxr'
- 'speex' 'srt' 'libssh' 'tensorflow' 'tesseract' 'libtheora' 'twolame'
- 'v4l-utils' 'vid.stab' 'libvorbis' 'libvpx' 'wavpack' 'libwebp' 'libx264.so'
+ 'alsa-lib' 'bzip2' 'frei0r-plugins' 'libgcrypt' 'gmp' 'gnutls' 'ladspa' 'libass'
+ 'aom' 'aribb24' 'libbluray' 'libbs2b' 'libcaca' 'celt' 'libcdio-paranoia' 'codec2'
+ 'dav1d' 'libdc1394' 'libavc1394' 'libfdk-aac' 'fontconfig' 'freetype2' 'fribidi'
+ 'glslang' 'libgme' 'gsm' 'libiec61883' 'libilbc' 'jack' 'kvazaar' 'lensfun'
+ 'libmodplug' 'lame' 'opencore-amr' 'openjpeg2' 'opus' 'pulseaudio' 'librabbitmq-c'
+ 'librsvg' 'rubberband' 'rtmpdump' 'snappy' 'libsoxr' 'speex' 'srt' 'libssh'
+ 'svt-hevc' 'svt-av1' 'svt-vp9' 'tensorflow' 'tesseract' 'libtheora' 'twolame'
+ 'v4l-utils' 'vid.stab' 'vmaf' 'libvorbis' 'libvpx' 'wavpack' 'libwebp' 'x264'
'x265' 'libxcb' 'xvidcore' 'libxml2' 'zimg' 'zeromq' 'zvbi' 'lv2' 'lilv' 'xz'
- 'openal' 'ocl-icd' 'libgl' 'sndio' 'sdl2' 'vapoursynth' 'libxv' 'libx11'
- 'libxext' 'zlib' 'libomxil-bellagio' 'libva' 'libdrm' 'libvdpau' 'dav1d'
+ 'libmysofa' 'openal' 'ocl-icd' 'libgl' 'sndio' 'sdl2' 'vapoursynth'
+ 'vulkan-icd-loader' 'libxv' 'libx11' 'libxext' 'zlib' 'libomxil-bellagio'
+ 'libdrm' 'libva' 'libvdpau'
# AUR:
- 'avisynthplus' 'chromaprint-fftw' 'codec2' 'davs2' 'flite1-patched' 'libilbc'
- 'libklvanc-git' 'kvazaar' 'openh264' 'libopenmpt-svn' 'shine' 'vo-amrwbenc'
- 'xavs' 'xavs2' 'libmysofa-git'
+ 'avisynthplus' 'chromaprint-fftw' 'davs2' 'flite1-patched' 'libklvanc-git'
+ 'openh264' 'libopenmpt-svn' 'rav1e' 'shine' 'vo-amrwbenc' 'xavs' 'xavs2'
+ 'pocketsphinx'
)
makedepends=(
# official repositories:
- 'git' 'nasm' 'opencl-headers'
+ 'git' 'nasm' 'opencl-headers' 'vulkan-headers' 'clang'
+ # AUR:
+ 'decklink-sdk' 'amf-headers-git'
)
makedepends_x86_64=(
# AUR:
@@ -42,10 +49,28 @@ provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libswresample.so' 'ffmpeg' 'ffmpeg-full' 'ffmpeg-git')
conflicts=('ffmpeg')
source=('git+https://git.ffmpeg.org/ffmpeg.git'
+ "ffmpeg-full-git-add-svt-hevc-${_svt_hevc_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v${_svt_hevc_ver}/ffmpeg_plugin/0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch"
+ "ffmpeg-full-git-add-svt-hevc-docs-${_svt_hevc_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/v${_svt_hevc_ver}/ffmpeg_plugin/0002-doc-Add-libsvt_hevc-encoder-docs.patch"
+ "ffmpeg-full-git-add-svt-av1-${_svt_av1_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-AV1/v${_svt_av1_ver}/ffmpeg_plugin/0001-Add-ability-for-ffmpeg-to-run-svt-av1-with-svt-hevc.patch"
+ "ffmpeg-full-git-add-svt-vp9-${_svt_vp9_ver}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/v${_svt_vp9_ver}/ffmpeg_plugin/0001-Add-ability-for-ffmpeg-to-run-svt-vp9-with-svt-hevc-av1.patch"
'LICENSE')
sha256sums=('SKIP'
+ '878757eb6d7072521caaeb71f1453ec3fc0f91a12936ef302e1625184787c6a6'
+ '1499e419dda72b1604dc5e3959668f3843292ff56bfba78734e31510ba576de0'
+ 'efbe348e0dad6b5f9fc501a34ff8304d82c2745ec9ac952e72f8549775c2fe78'
+ '7690a4f6bdc4a57e35c7ff5b6e87f2fe6d056d452eff9e767eaccff41832f4d7'
'04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')
+prepare() {
+ cd ffmpeg
+
+ # add svt codec support for hevc, av1 and vp9
+ git apply --index "${srcdir}/ffmpeg-full-git-add-svt-hevc-${_svt_hevc_ver}.patch"
+ patch -Np1 -i "${srcdir}/ffmpeg-full-git-add-svt-hevc-docs-${_svt_hevc_ver}.patch"
+ git apply --index "${srcdir}/ffmpeg-full-git-add-svt-av1-${_svt_av1_ver}.patch"
+ git apply --index "${srcdir}/ffmpeg-full-git-add-svt-vp9-${_svt_vp9_ver}.patch"
+}
+
pkgver() {
cd "$_srcname"
@@ -67,8 +92,9 @@ build() {
./configure \
--prefix='/usr' \
- --extra-cflags="$_cflags" \
+ --extra-cflags="-I/usr/include/tensorflow" \
--extra-ldflags="$_ldflags" \
+ \
--disable-rpath \
--enable-gpl \
--enable-version3 \
@@ -78,6 +104,7 @@ build() {
--disable-stripping \
--enable-gray \
--enable-avresample \
+ \
--enable-alsa \
--enable-avisynth \
--enable-bzlib \
@@ -89,6 +116,7 @@ build() {
--enable-iconv \
--enable-ladspa \
--enable-libaom \
+ --enable-libaribb24 \
--enable-libass \
--enable-libbluray \
--enable-libbs2b \
@@ -104,6 +132,7 @@ build() {
--enable-fontconfig \
--enable-libfreetype \
--enable-libfribidi \
+ --enable-libglslang \
--enable-libgme \
--enable-libgsm \
--enable-libiec61883 \
@@ -122,6 +151,8 @@ build() {
--enable-libopenmpt \
--enable-libopus \
--enable-libpulse \
+ --enable-librabbitmq \
+ --enable-librav1e \
--enable-librsvg \
--enable-librubberband \
--enable-librtmp \
@@ -130,8 +161,11 @@ build() {
--enable-libsnappy \
--enable-libsoxr \
--enable-libspeex \
- --disable-libsrt \
+ --enable-libsrt \
--enable-libssh \
+ --enable-libsvthevc \
+ --enable-libsvtav1 \
+ --enable-libsvtvp9 \
--enable-libtensorflow \
--enable-libtesseract \
--enable-libtheora \
@@ -160,33 +194,35 @@ build() {
--enable-libzvbi \
--enable-lv2 \
--enable-lzma \
+ --enable-decklink \
--disable-mbedtls \
--enable-libmysofa \
--enable-openal \
--enable-opencl \
--enable-opengl \
--disable-openssl \
+ --enable-pocketsphinx \
--enable-sndio \
--enable-sdl2 \
--enable-vapoursynth \
+ --enable-vulkan \
--enable-xlib \
--enable-zlib \
+ \
+ --enable-amf \
--enable-libdrm \
--enable-omx \
--enable-v4l2-m2m \
--enable-vaapi \
--enable-vdpau \
- --extra-cflags='-I/usr/include/tensorflow'
+
make
make tools/qt-faststart
}
package() {
- cd "$_srcname"
-
- make DESTDIR="$pkgdir" install
-
- install -D -m755 tools/qt-faststart -t "${pkgdir}/usr/bin"
- install -D -m644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ make -C ffmpeg DESTDIR="$pkgdir" install
+ install -D -m755 ffmpeg/tools/qt-faststart -t "${pkgdir}/usr/bin"
+ install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}