summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMuflone2015-06-13 18:23:36 +0200
committerMuflone2015-06-13 18:23:36 +0200
commitfc3a53baf505eb70b3b929fc8ac048866d185dc4 (patch)
treef13af61ff3743be4783c57278299ee7aede08b31 /PKGBUILD
downloadaur-fc3a53baf505eb70b3b929fc8ac048866d185dc4.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD71
1 files changed, 71 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c84888c273fa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+
+pkgname=ffmpeg-compat-55
+pkgver=2.3.4
+pkgrel=2
+pkgdesc="Compatibility package for ffmpeg to provide versions 55 of libavcodec, libavdevice and libavformat, not anymore provided by the ffmpeg package"
+arch=('i686' 'x86_64')
+url="http://ffmpeg.org/"
+license=('GPL')
+depends=('gsm' 'lame' 'opencore-amr' 'openjpeg' 'opus' 'rtmpdump' 'libvpx'
+ 'schroedinger' 'speex' 'v4l-utils' 'xvidcore' 'libpulse' 'libx264'
+ 'libtheora' 'libbluray' 'libmodplug' 'libva' 'libxv' 'sdl' 'jack'
+ 'libavutil-52')
+makedepends=('yasm' 'libass')
+source=("http://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.bz2")
+sha256sums=('2f7dece56ea72a22c7cf49e50b58eaadef340457404395cc0479c843b42344f8')
+
+build() {
+ cd "ffmpeg-${pkgver}"
+ ./configure \
+ --prefix=/usr \
+ --incdir="/usr/include" \
+ --shlibdir="/usr/lib" \
+ --libdir="/usr/lib" \
+ --disable-debug \
+ --disable-static \
+ --enable-dxva2 \
+ --disable-fontconfig \
+ --enable-gpl \
+ --enable-libass \
+ --enable-libbluray \
+ --enable-libfreetype \
+ --enable-libgsm \
+ --enable-libmodplug \
+ --enable-libmp3lame \
+ --enable-libopencore_amrnb \
+ --enable-libopencore_amrwb \
+ --enable-libopenjpeg \
+ --enable-libopus \
+ --enable-libpulse \
+ --enable-librtmp \
+ --enable-libschroedinger \
+ --enable-libspeex \
+ --enable-libtheora \
+ --enable-libv4l2 \
+ --enable-libvorbis \
+ --enable-libvpx \
+ --enable-libx264 \
+ --enable-libxvid \
+ --enable-runtime-cpudetect \
+ --enable-shared \
+ --enable-vdpau \
+ --enable-version3 \
+ --enable-x11grab \
+ --disable-doc \
+ --disable-programs \
+ --disable-avresample \
+ --disable-avfilter \
+ --disable-postproc \
+ --disable-swresample \
+ --disable-swscale
+ make
+}
+
+package() {
+ cd "ffmpeg-${pkgver}"
+ make DESTDIR="${pkgdir}" install-libs
+ cd "${pkgdir}/usr/lib"
+ rm -f *.so libavutil.*
+}
+