summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRandyW2018-05-23 11:33:34 +0200
committerRandyW2018-05-23 11:33:34 +0200
commitfd6cec67fa22ec6454b17d02b5a0a08dcc9c1cdc (patch)
tree8011558ee8fb9bb97024f809ac5085fca1caa657 /PKGBUILD
parent8e7873f50cd9658457e67f5e0df79e5f7b0b4158 (diff)
downloadaur-fd6cec67fa22ec6454b17d02b5a0a08dcc9c1cdc.tar.gz
Updated to ffmpeg 3.4.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD85
1 files changed, 48 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 52322a3bf22c..1fb3f2669ecd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,65 @@
# Maintainer: Muflone http://www.muflone.com/contacts/english/
pkgname=ffmpeg-compat-57
-pkgver=3.3.4
-pkgrel=2
+pkgver=3.4.2
+pkgrel=1
pkgdesc="Compatibility package for ffmpeg to provide versions 57 of libavcodec, libavdevice and libavformat, not anymore provided by the ffmpeg package"
arch=('i686' 'x86_64')
url="http://ffmpeg.org/"
license=('GPL')
-depends=('bzip2' 'fribidi' 'glibc' 'gmp' 'gnutls' 'gsm'
- 'lame' 'libmodplug'
- 'libtheora' 'libva'
- 'libwebp' 'opencore-amr' 'openjpeg2' 'opus'
- 'schroedinger' 'speex' 'v4l-utils' 'xz' 'zlib'
- 'libbluray.so>=2-64'
- 'libvorbisenc.so>=2-64' 'libvorbis.so>=0-64' 'libvpx.so>=5-64'
- 'libx264.so>=152-64' 'libx265.so>=146-64' 'libxvidcore.so>=4-64'
- 'rtmpdump')
-makedepends=('yasm')
-provides=('libavcodec.so=57' 'libavdevice.so=57' 'libavformat.so=57' 'libavutils.so=55')
+depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'glibc' 'gmp' 'gnutls' 'gsm'
+ 'jack' 'lame' 'libavc1394' 'libiec61883' 'libmodplug' 'libpulse'
+ 'libraw1394' 'libsoxr' 'libssh' 'libtheora' 'libvdpau' 'libwebp'
+ 'libx11' 'libxcb' 'libxml2' 'opencore-amr' 'openjpeg2' 'opus' 'sdl2'
+ 'speex' 'v4l-utils' 'xz' 'zlib'
+ 'libomxil-bellagio'
+ 'libass.so' 'libbluray.so' 'libfreetype.so' 'libva-drm.so' 'libva.so'
+ 'libva-x11.so' 'libvidstab.so' 'libvorbisenc.so' 'libvorbis.so'
+ 'libvpx.so' 'libx264.so' 'libx265.so' 'libxvidcore.so')
+makedepends=('yasm' 'libvdpau')
+provides=('libavcodec.so=57' 'libavdevice.so=57' 'libavfilter.so=6'
+ 'libavformat.so=57' 'libavresample.so=3' 'libavutil.so=55'
+ 'libpostproc.so=54' 'libswresample.so=2' 'libswscale.so=4')
source=("http://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"{,.asc}
- "ffmpeg-openjpeg2.2.patch")
-sha256sums=('98b97e1b908dfeb6aeb6d407e5a5eacdfc253a40c2d195f5867ed2d1d46ea957'
+ "fs56089.patch")
+sha256sums=('2b92e9578ef8b3e49eeab229e69305f5f4cbc1fdaa22e927fc7fca18acccd740'
'SKIP'
- '490598f78d7879af8ef5b8d7f92ada83d0ee64f9609f6c7b989eb331c2539f68')
+ '0bfcd12d1992903f21c146ae56d9ad89b52818cfb2303197ee905347c25a5427')
validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
prepare() {
cd "ffmpeg-${pkgver}"
- patch -Np1 -i ../ffmpeg-openjpeg2.2.patch
+
+ # https://bugs.archlinux.org/task/56089
+ # Backport of http://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=a606f27f4c610708fa96e35eed7b7537d3d8f712
+ patch -Np1 -i ../fs56089.patch
}
build() {
- cd "ffmpeg-${pkgver}"
+ cd ffmpeg-${pkgver}
+
./configure \
- --prefix=/usr \
- --incdir="/usr/include" \
- --shlibdir="/usr/lib" \
- --libdir="/usr/lib" \
+ --prefix='/usr' \
+ --incdir='/usr/include' \
+ --shlibdir='/usr/lib' \
+ --libdir='/usr/lib' \
--disable-debug \
+ --disable-doc \
+ --disable-programs \
--disable-static \
- --disable-fontconfig \
+ --disable-stripping \
+ --enable-avisynth \
+ --enable-avresample \
+ --enable-fontconfig \
+ --enable-gmp \
+ --enable-gnutls \
--enable-gpl \
--enable-libass \
--enable-libbluray \
--enable-libfreetype \
+ --enable-libfribidi \
--enable-libgsm \
+ --enable-libiec61883 \
--enable-libmodplug \
--enable-libmp3lame \
--enable-libopencore_amrnb \
@@ -52,34 +67,30 @@ build() {
--enable-libopenjpeg \
--enable-libopus \
--enable-libpulse \
- --enable-librtmp \
- --enable-libschroedinger \
+ --enable-libsoxr \
--enable-libspeex \
+ --enable-libssh \
--enable-libtheora \
--enable-libv4l2 \
+ --enable-libvidstab \
--enable-libvorbis \
--enable-libvpx \
+ --enable-libwebp \
--enable-libx264 \
--enable-libx265 \
+ --enable-libxcb \
+ --enable-libxml2 \
--enable-libxvid \
- --enable-runtime-cpudetect \
--enable-shared \
- --enable-vdpau \
- --enable-version3 \
- --disable-doc \
- --disable-programs \
- --disable-avresample \
- --disable-avfilter \
- --disable-postproc \
- --disable-swresample \
- --disable-swscale
+ --enable-version3
+
make
}
package() {
- cd "ffmpeg-${pkgver}"
+ cd ffmpeg-${pkgver}
+
make DESTDIR="${pkgdir}" install-libs
cd "${pkgdir}/usr/lib"
rm -f *.so
}
-