summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-05-02 17:18:19 +0000
committerDaniel Bermond2018-05-02 17:44:04 +0000
commitca35bc5bae7c614b57c872c90e85835dd2a6c23d (patch)
treec5d807d7b4a0521729f559ac8d7f5a578512814c /PKGBUILD
parent2c3d4a857aaf4cf3b43d69a2a463c765fb8f3429 (diff)
downloadaur-ca35bc5bae7c614b57c872c90e85835dd2a6c23d.tar.gz
depends_x86_64: remove nvidia-utils (now provided by cuda)
nvidia-utils is now a dependency for cuda, so we do not need to specify it here anymore. Although I prefer to explicitly list dependencies, nvidia-utils is a cuda component because it provides 'libcuda.so.1'. So it makes sense to let it only with cuda. References ---------- https://bugs.archlinux.org/task/58408 https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/cuda&id=b9d76ab707c8deb25cd9734e99e15e965f05f570
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 488f463c0d5a..88eb6004ea38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=ffmpeg-full
_srcname=ffmpeg
pkgver=4.0
-pkgrel=1
+pkgrel=2
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features including nvenc, qsv and libfdk-aac)'
arch=('i686' 'x86_64')
url='http://www.ffmpeg.org/'
@@ -28,7 +28,7 @@ depends=(
)
depends_x86_64=(
# official repositories:
- 'cuda' 'nvidia-utils'
+ 'cuda'
# AUR:
'intel-media-sdk'
)
@@ -215,6 +215,7 @@ build() {
package() {
cd "${_srcname}-${pkgver}"
+
make DESTDIR="$pkgdir" install
install -D -m755 tools/qt-faststart "${pkgdir}/usr/bin/qt-faststart"