summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-11-09 15:56:45 -0200
committerDaniel Bermond2017-11-09 15:56:45 -0200
commit20ce47d5b9ee79899cb67a1db1420df194868464 (patch)
treea95cdf9dd247ec7b62b38ea56bc5882d10b95fed /PKGBUILD
parent4dfa91ad47336dff41e8edfaa8ec0c103aec19d7 (diff)
downloadaur-20ce47d5b9ee79899cb67a1db1420df194868464.tar.gz
Fix build in i686 architecture
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8bea0e7fb2e0..6866fbbf450c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# and add '--enable-libndi_newtek' to the configure options.
pkgname=ffmpeg-full-git
-pkgver=3.5.r88519.gcf5a6c754a
-pkgrel=2
+pkgver=3.5.r88673.gdfa859b85a
+pkgrel=1
pkgdesc='Record, convert and stream audio and video (all possible features including nvenc, qsv and libfdk-aac; git version)'
arch=('i686' 'x86_64')
url='http://www.ffmpeg.org/'
@@ -71,7 +71,7 @@ build() {
local _cudasdk='--enable-cuda-sdk'
local _cuvid='--enable-cuvid'
local _libnpp='--enable-libnpp'
- local _cflags='--extra-cflags=-I/opt/cuda/include'
+ local _cflags='-I/opt/cuda/include'
# '-L/usr/lib/nvidia' (for cuda_sdk) needs to be enabled only on
# systems with nvidia-340xx-utils or nvidia-304xx-utils
@@ -80,7 +80,8 @@ build() {
then
local _nvidia_340xx_ldflags='-L/usr/lib/nvidia'
fi
- local _ldflags="--extra-ldflags=-L/opt/cuda/lib64 ${_nvidia_340xx_ldflags}"
+
+ local _ldflags="-L/opt/cuda/lib64 ${_nvidia_340xx_ldflags}"
local _ldflags="${_ldflags} -Wl,-rpath -Wl,/opt/intel/mediasdk/lib64:/opt/intel/mediasdk/plugins"
# strictly specifying nvcc path is needed if package is installing
@@ -92,8 +93,8 @@ build() {
./configure \
--prefix='/usr' \
- $_cflags \
- "$_ldflags" \
+ --extra-cflags="${_cflags}" \
+ --extra-ldflags="${_ldflags}" \
\
--disable-rpath \
--enable-gpl \