summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-11-02 22:06:56 -0200
committerDaniel Bermond2017-11-02 22:06:56 -0200
commit4ea239bdc900ef86abf9dd8ce84d340928b7a90c (patch)
tree4e7352c4dbadb4138168fcc3ff6e04ed6f6eedc2 /PKGBUILD
parentcb60302a808d459248f4f69c116d696e93c072df (diff)
downloadaur-4ea239bdc900ef86abf9dd8ce84d340928b7a90c.tar.gz
Disable openssl (upstream now prevents using gnutls + openssl)
gnutls and openssl cannot be used together anymore. Otherwise, configure script will fail with the following message: "GnuTLS and OpenSSL must not be enabled at the same time" Now it's necessary to use only one of them. Quote directly from ffmpeg upstream commit that originated this: "Both libraries provide similar functionality and cannot be used together. When both are enabled one is used and the other ignored arbitrarily. Error out instead and have the user choose which library to use." Since ffmpeg from Arch official repositories uses gnutls, let's stick with it. References ---------- http://git.videolan.org/?p=ffmpeg.git;a=commit;h=4600b0619afc58b58de1a21d7a2c472e0d788282 http://git.videolan.org/?p=ffmpeg.git;a=commit;h=ed434be106a4615e0419b3ac7664220741afda2d
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c1431acaf24..c4f69174d888 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# and add '--enable-libndi_newtek' to the configure options.
pkgname=ffmpeg-full-git
-pkgver=3.4.r88116.gacf70639fb
+pkgver=3.5.r88519.gcf5a6c754a
pkgrel=1
pkgdesc='Record, convert and stream audio and video (all possible features including nvenc, qsv and libfdk-aac; git version)'
arch=('i686' 'x86_64')
@@ -21,8 +21,8 @@ depends=(
'librsvg' 'rubberband' 'rtmpdump' 'smbclient' 'snappy' 'libsoxr' 'speex'
'libssh' 'tesseract' 'libtheora' 'twolame' 'v4l-utils' 'vid.stab' 'libvorbis'
'libvpx' 'wavpack' 'libwebp' 'libx264.so' 'x265' 'libxcb' 'xvidcore' 'libxml2'
- 'zimg' 'zeromq' 'zvbi' 'xz' 'openal' 'opencl-icd-loader' 'mesa' 'openssl'
- 'sdl2' 'libx11' 'zlib' 'libomxil-bellagio' 'libva' 'libdrm' 'libvdpau'
+ 'zimg' 'zeromq' 'zvbi' 'xz' 'openal' 'opencl-icd-loader' 'mesa' 'sdl2'
+ 'libx11' 'zlib' 'libomxil-bellagio' 'libva' 'libdrm' 'libvdpau'
# AUR:
'chromaprint-fftw' 'libbs2b' 'libilbc' 'kvazaar' 'openh264'
'libopenmpt-svn' 'sndio' 'shine' 'vo-amrwbenc' 'xavs' 'libmysofa' 'rockchip-mpp'
@@ -180,7 +180,7 @@ build() {
--enable-openal \
--enable-opencl \
--enable-opengl \
- --enable-openssl \
+ --disable-openssl \
--enable-sndio \
--enable-sdl2 \
--enable-xlib \