summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-09-13 16:35:35 -0300
committerDaniel Bermond2017-09-13 16:35:35 -0300
commit4ef0bb49c602ee0719c687c05b3f9e767dac375c (patch)
tree946c25a623e7997bfc9f72be6df56635387ad555 /PKGBUILD
parentf37bcddcbca31ed3b2be95e2cfa422f2e2f5b4d9 (diff)
downloadaur-4ef0bb49c602ee0719c687c05b3f9e767dac375c.tar.gz
Readded cuda-sdk after cuda fix for glibc 2.26
References ---------- https://aur.archlinux.org/cgit/aur.git/commit/?h=ffmpeg-full-git&id=f37bcddcbca31ed3b2be95e2cfa422f2e2f5b4d9 https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/cuda&id=ae90e4d243510e9565e66e9e8e08c509f5719fe0 https://bugs.archlinux.org/task/55580
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e71a264a7e61..8206673f455b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=ffmpeg-full-git
pkgver=3.4.r87251.ga918f16f7c
-pkgrel=1
+pkgrel=2
pkgdesc='Record, convert and stream audio and video (all possible features including nvenc, qsv and libfdk-aac; git version)'
arch=('i686' 'x86_64')
url='http://www.ffmpeg.org/'
@@ -68,7 +68,7 @@ build() {
if [ "$CARCH" = 'x86_64' ]
then
local _cuda='--enable-cuda'
- local _cudasdk='--disable-cuda-sdk'
+ local _cudasdk='--enable-cuda-sdk'
local _cuvid='--enable-cuvid'
local _libnpp='--enable-libnpp'
local _cflags='--extra-cflags=-I/opt/cuda/include'
@@ -84,8 +84,8 @@ build() {
local _ldflags="${_ldflags} -Wl,-rpath -Wl,/opt/intel/mediasdk/lib64"
# strictly specifying nvcc path is needed if package is installing
- # cuda for the first time
- sed -i 's@^nvcc_default=.*@nvcc_default=\"/opt/cuda/bin/nvcc\"@' configure
+ # cuda for the first time (nvcc path will be in $PATH only after relogin)
+ sed -i "s@^nvcc_default=.*@nvcc_default='/opt/cuda/bin/nvcc'@" configure
fi
msg2 'Running ffmpeg configure script. Please wait...'