summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-05-31 19:27:53 -0300
committerDaniel Bermond2017-05-31 19:27:53 -0300
commit55307e30bbd33cca865b5cf4cc7e042a226de459 (patch)
tree02d9a5c53a34d37f4ae85ad34c5375cb34430b1f /PKGBUILD
parent02cee1e9f4674564c1811f50de889d0dfa60d4cb (diff)
downloadaur-55307e30bbd33cca865b5cf4cc7e042a226de459.tar.gz
license: changed to just nonfree and unredistributable
Although GPL3 is present in the resuling complex license mix, it does not seem to make sense leaving GPL3 in the license list. The output of configure script clearly says that the resulting license is nonfree and unredistributable, and this is what should be clearly stated to the user. The ffmpeg documentation says that in such cases, like we are using here with --enable-nonfree, the resulting binaries are under a complex and restrictive license mix. But it does not provide clear licensing terms for such situation. So I just created a LICENSE file and added generic notes to it which seems to better describe this nature than the previously used UNREDISTRIBUTABLE.txt file. Also, the presence of a LICENSE file is something more standard and is described in the Wiki. References: ----------- https://github.com/FFmpeg/FFmpeg/blob/a47273c803edfbc43793349b74429ae29b05c003/configure#L101-L102 https://github.com/FFmpeg/FFmpeg/blob/a47273c803edfbc43793349b74429ae29b05c003/configure#L6554-L6555 https://github.com/FFmpeg/FFmpeg/blob/a47273c803edfbc43793349b74429ae29b05c003/LICENSE.md#incompatible-libraries https://ffmpeg.org/pipermail/libav-user/2012-November/003179.html
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce364768c1e8..c198e582f837 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
pkgname=ffmpeg-full-git
-pkgver=N.86313.g87bddba43b
-pkgrel=6
+pkgver=N.86329.ga47273c803
+pkgrel=1
pkgdesc="Record, convert and stream audio and video (Git version with all possible libs)"
arch=('i686' 'x86_64')
url="http://www.ffmpeg.org/"
-license=('GPL3' 'custom:UNREDISTRIBUTABLE')
+license=('custom:nonfree and unredistributable')
depends=(
# official repositories:
'glibc' 'alsa-lib' 'jack' 'libpng'
@@ -43,9 +43,9 @@ conflicts=(
'ffmpeg' 'ffmpeg-git' 'ffmpeg-full' 'ffmpeg-full-extra' 'ffmpeg-full-nvenc'
'ffmpeg-libfdk_aac')
source=("$pkgname"::'git://source.ffmpeg.org/ffmpeg.git'
- 'UNREDISTRIBUTABLE.txt')
+ 'LICENSE')
sha256sums=('SKIP'
- 'e0c1b126862072a71e18b9580a6b01afc76a54aa6e642d2c413ba0ac9d3010c4')
+ '04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')
pkgver() {
cd "$pkgname"
@@ -194,5 +194,5 @@ package() {
make DESTDIR="$pkgdir/" install
install -D -m755 tools/qt-faststart "${pkgdir}/usr/bin/qt-faststart"
- install -D -m644 "${srcdir}/UNREDISTRIBUTABLE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/UNREDISTRIBUTABLE.txt"
+ install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}