summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBermond2016-05-01 00:55:30 -0300
committerBermond2016-05-01 00:55:30 -0300
commit5c4b1a10ee0c37c4b60b48b700f40a5f6891a06c (patch)
treef73caeba1f7b2f7d4c4da85b48462a0ce8818a1c /PKGBUILD
parent8d5a2d22b44e23298272e3608dc3eaa5eb62a98a (diff)
downloadaur-5c4b1a10ee0c37c4b60b48b700f40a5f6891a06c.tar.gz
New upstream option: --enable-libnpp (x86_64 only)
libnpp depends on cuda, which is already included
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b085a333884d..aa9459d3ecc4 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@
# intel-media-sdk (experimental Intel QSV support only for x86_64)
pkgname=ffmpeg-full-git
-pkgver=N.79160.gb73c271
+pkgver=N.79701.gb286ff6
pkgrel=1
pkgdesc="Record, convert and stream audio and video (Git version with all possible libs)"
arch=('i686' 'x86_64')
@@ -74,11 +74,13 @@ build() {
_cuda="--enable-cuda"
_cudainc="-I/opt/cuda/include"
_cudalib="-L/opt/cuda/lib64"
+ _libnpp="--enable-libnpp"
_intelsdklib="-Wl,-rpath -Wl,/opt/intel/mediasdk/lib64"
else
_cuda=""
_cudainc=""
_cudalib=""
+ _libnpp=""
_intelsdklib=""
fi
@@ -133,6 +135,7 @@ build() {
--enable-libmodplug \
--enable-libmp3lame \
--enable-libnut \
+ $_libnpp \
--enable-libopencore-amrnb \
--enable-libopencore-amrwb \
--enable-libopencv \