summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2016-11-26 14:52:42 -0200
committerDaniel Bermond2016-11-26 14:52:42 -0200
commit8fed268043cb2c3fcbcab550c429caf4e7f0e300 (patch)
tree386ef8780d67f1f4c41c7ff68f580f8998ad2e09 /PKGBUILD
parentecf5fd28f670132af5af5e35e85754384ee8ea06 (diff)
downloadaur-8fed268043cb2c3fcbcab550c429caf4e7f0e300.tar.gz
depends: change zimg to zimg-git due to compile error
The following compile error occurs if using zimg release version (currently at 2.3): libavfilter/vf_zscale.c:387:16: error: ‘ZIMG_TRANSFER_IEC_61966_2_1’ undeclared (first use in this function) FFmpeg seems to be using code from zimg git version since using zimg-zit fix this error. This was introduced in the following upstream git commit: http://git.videolan.org/?p=ffmpeg.git;a=commit;h=b96a6e2024fa2b52d6a2473a7cf16ee20a8ab5c8 When zimg releases a new version we can consider to change back this dependency.
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d911f1ae08f9..159cdb337c99 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# AUR dependencies
# ----------------
# libilbc kvazaar chromaprint-fftw libbs2b openh264 shine vo-amrwbenc
-# nut-multimedia-git xavs flite-fpic libmfx-git libopenmpt-svn
+# nut-multimedia-git xavs flite-fpic libmfx-git libopenmpt-svn zimg-git
# AUR make dependencies
# ---------------------
@@ -18,7 +18,7 @@
# intel-media-sdk (experimental Intel QSV support only for x86_64)
pkgname=ffmpeg-full-git
-pkgver=N.82400.gb1367f7
+pkgver=N.82645.g829db8e
pkgrel=1
pkgdesc="Record, convert and stream audio and video (Git version with all possible libs)"
arch=('i686' 'x86_64')
@@ -32,7 +32,7 @@ depends=(
'opencore-amr' 'opencv' 'openh264' 'openjpeg2' 'libopenmpt-svn' 'opus' 'pulseaudio'
'rubberband' 'rtmpdump' 'schroedinger' 'shine' 'smbclient' 'libavc1394' 'snappy' 'libsoxr'
'speex' 'libssh' 'tesseract' 'libtheora' 'twolame' 'v4l-utils' 'vid.stab' 'vo-amrwbenc'
- 'libvorbis' 'libvpx' 'wavpack' 'libwebp' 'libx264.so' 'x265' 'libxcb' 'xvidcore' 'zimg'
+ 'libvorbis' 'libvpx' 'wavpack' 'libwebp' 'libx264.so' 'x265' 'libxcb' 'xvidcore' 'zimg-git'
'zeromq' 'zvbi' 'openal' 'libva' 'libdrm' 'libva-intel-driver' 'opencl-headers' 'ocl-icd'
'libvdpau' 'mesa' 'openssl' 'xavs' 'sdl2' 'java-environment' 'libmfx-git' 'libomxil-bellagio'
)