summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2022-11-02 10:59:58 -0300
committerDaniel Bermond2022-11-02 10:59:58 -0300
commitb32253ce4c88833bb3358c5fdb689e00975c2d2e (patch)
tree1a3dda880fdace1cc8fd75cfda3a3ae3f6c31f54 /PKGBUILD
parent4a77bd4f9df8bec81b5f4c1e22d2455cd4957ba9 (diff)
downloadaur-b32253ce4c88833bb3358c5fdb689e00975c2d2e.tar.gz
Match latest upstream changes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3f79e74afc0d..65979a558925 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=ffmpeg-full-git
-pkgver=5.2.r108314.gec8be8a913
+pkgver=5.2.r108915.g5661c8715c
pkgrel=1
_svt_hevc_ver='b62f72e752243cee4104cfb41dc7ee409d3ac3e9'
_svt_vp9_ver='d9ef3cc13159143b9afc776c04f67cdfa6284046'
@@ -126,6 +126,7 @@ provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'ffmpeg' 'ffmpeg-full' 'ffmpeg-git')
conflicts=('ffmpeg')
source=('git+https://git.ffmpeg.org/ffmpeg.git'
+ "005-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"
"010-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/${_svt_hevc_ver}/ffmpeg_plugin/master-0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch"
#"020-ffmpeg-add-svt-hevc-docs-g${_svt_hevc_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/${_svt_hevc_ver}/ffmpeg_plugin/0002-doc-Add-libsvt_hevc-encoder-docs.patch"
"030-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/${_svt_vp9_ver}/ffmpeg_plugin/master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9.patch"
@@ -133,14 +134,18 @@ source=('git+https://git.ffmpeg.org/ffmpeg.git'
'060-ffmpeg-fix-segfault-with-avisynthplus.patch'
'LICENSE')
sha256sums=('SKIP'
+ '52c7f9299b9cb3ad47ef580a7732c5a2c6367d406284ad4c5acd430d718b0e5c'
'4da3826aa370572273ef9fb4c0bf2c93a840595b07a671a0412ad0dc9ed8d689'
'e310eedb3dc88c8ad6ffcd6cb6bde1f593ded330ea99b0356724c9d22bcfde4c'
- '2df82046908015bf26bc1303275cf52ba01fa380029a54ea6415373e389e423c'
- 'b1d68f626168f2409a4b0987acf5b208e7ced2ddab49b11990a10f458d377e9a'
+ '3f4d677da3efdc3d2a1cbd36257d626b7e4c05d685ed82bd1a7e2eb7e3ac6ee4'
+ 'bf563193f450ece58a93db6840c0db33875df945fa81477b9b02fb209d3bf57a'
'04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')
prepare() {
rm -f ffmpeg/libavcodec/libsvt_{hevc,vp9}.c
+ cp --remove-destination "$(readlink "010-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch")" \
+ "010-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"
+ patch -Np1 -i "005-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"
patch -d ffmpeg -Np1 -i "${srcdir}/010-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"
#patch -d ffmpeg -Np1 -i "${srcdir}/020-ffmpeg-add-svt-hevc-docs-g${_svt_hevc_ver:0:7}.patch"
patch -d ffmpeg -Np1 -i "${srcdir}/030-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"