summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBermond2016-03-19 10:53:24 -0300
committerBermond2016-03-19 10:53:24 -0300
commitc60138943f34df3d63dee673a850465821f05799 (patch)
treeb51e337466a21dbd21a49e4ad7927d53054ffd98 /PKGBUILD
parent03c71b21b6995f34d730f7b5c616b42ed8a679dc (diff)
downloadaur-c60138943f34df3d63dee673a850465821f05799.tar.gz
Fixed cuda errors and warnings
Removing quotation marks from the _cuda variable when running the configure script prevents it from giving an error when building in i686 systems (where _cuda variable is empty). Passing cuda libraries to the configure script using the gcc -L flag prevents ffmpeg to give warnings right after its execution (/opt/cuda/lib64/libOpenCL.so.1: no version information available)
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4be3766ecaf2..6bd4bffe714d 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@
# intel-media-sdk (experimental Intel QSV support only for x86_64)
pkgname=ffmpeg-full-git
-pkgver=N.79022.g58cb1fb
+pkgver=N.79085.g48bda6c
pkgrel=1
pkgdesc="Record, convert and stream audio and video (Git version with all possible libs)"
arch=('i686' 'x86_64')
@@ -73,7 +73,7 @@ build() {
if [ "$CARCH" = "x86_64" ]; then
_cuda="--enable-cuda"
_cudainc="-I/opt/cuda/include"
- _cudalib=":/opt/cuda/lib64"
+ _cudalib="-L/opt/cuda/lib64"
else
_cuda=""
_cudainc=""
@@ -88,7 +88,7 @@ build() {
${_cudainc} \
-I/usr/lib/jvm/java-8-openjdk/include \
-I/usr/lib/jvm/java-8-openjdk/include/linux" \
- --extra-ldflags="-Wl,-rpath -Wl,/opt/intel/mediasdk/lib64${_cudalib}" \
+ --extra-ldflags="${_cudalib} -Wl,-rpath -Wl,/opt/intel/mediasdk/lib64" \
\
--enable-rpath \
--enable-gpl \
@@ -101,7 +101,7 @@ build() {
--enable-videotoolbox \
\
--enable-avisynth \
- "$_cuda" \
+ $_cuda \
--enable-chromaprint \
--enable-fontconfig \
--enable-frei0r \