summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBermond2016-03-21 14:34:03 -0300
committerBermond2016-03-21 14:34:03 -0300
commitcdd58fa4a3fd86c83623769196b52b2d933b69b4 (patch)
tree3407530b57264ceabeefd2b06dffd10bad218bf2 /PKGBUILD
parentc60138943f34df3d63dee673a850465821f05799 (diff)
downloadaur-cdd58fa4a3fd86c83623769196b52b2d933b69b4.tar.gz
Intel Media SDK lib path shows in configuration string only in x86_64
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6bd4bffe714d..5e6d9b9ea266 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@
# intel-media-sdk (experimental Intel QSV support only for x86_64)
pkgname=ffmpeg-full-git
-pkgver=N.79085.g48bda6c
+pkgver=N.79100.g8f66a2d
pkgrel=1
pkgdesc="Record, convert and stream audio and video (Git version with all possible libs)"
arch=('i686' 'x86_64')
@@ -69,15 +69,17 @@ prepare() {
build() {
cd "${srcdir}/${pkgname}"
- # Add cuda to the build if architecture is x86_64 (cuda is x86_64 only)
+ # Add x86_64 depends and optdepends to the build if architecture is x86_64
if [ "$CARCH" = "x86_64" ]; then
_cuda="--enable-cuda"
_cudainc="-I/opt/cuda/include"
_cudalib="-L/opt/cuda/lib64"
+ _intelsdklib="-Wl,-rpath -Wl,/opt/intel/mediasdk/lib64"
else
_cuda=""
_cudainc=""
_cudalib=""
+ _intelsdklib=""
fi
msg2 "Running ffmpeg configure script. Please wait..."
@@ -88,7 +90,7 @@ build() {
${_cudainc} \
-I/usr/lib/jvm/java-8-openjdk/include \
-I/usr/lib/jvm/java-8-openjdk/include/linux" \
- --extra-ldflags="${_cudalib} -Wl,-rpath -Wl,/opt/intel/mediasdk/lib64" \
+ --extra-ldflags="${_cudalib} ${_intelsdklib}" \
\
--enable-rpath \
--enable-gpl \