summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2017-09-13 16:40:49 -0300
committerDaniel Bermond2017-09-13 16:40:49 -0300
commitdc22ba37209d20a430db8b32cf7258569b5fcf69 (patch)
treee11b4318dc46c40909fe47a4863314ad8cda958c /PKGBUILD
parent4ef0bb49c602ee0719c687c05b3f9e767dac375c (diff)
downloadaur-dc22ba37209d20a430db8b32cf7258569b5fcf69.tar.gz
Added Intel Media SDK plugins path for hw-accelerated QSV encoders
This seems to not work currently with the Intel binary version of Media SDK. But the correct is to provide this path for ffmpeg to try the hardware accelerated encoders before falling back to software mode. Only software mode seems to be working currently, and then intel-media-sdk optdepend will still remain marked as experimental.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8206673f455b..a2423e591ec7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
# and add '--enable-libndi_newtek' to the configure options.
pkgname=ffmpeg-full-git
-pkgver=3.4.r87251.ga918f16f7c
-pkgrel=2
+pkgver=3.4.r87287.g4d390344ec
+pkgrel=1
pkgdesc='Record, convert and stream audio and video (all possible features including nvenc, qsv and libfdk-aac; git version)'
arch=('i686' 'x86_64')
url='http://www.ffmpeg.org/'
@@ -81,7 +81,7 @@ build() {
local _nvidia_340xx_ldflags='-L/usr/lib/nvidia'
fi
local _ldflags="--extra-ldflags=-L/opt/cuda/lib64 ${_nvidia_340xx_ldflags}"
- local _ldflags="${_ldflags} -Wl,-rpath -Wl,/opt/intel/mediasdk/lib64"
+ local _ldflags="${_ldflags} -Wl,-rpath -Wl,/opt/intel/mediasdk/lib64:/opt/intel/mediasdk/plugins"
# strictly specifying nvcc path is needed if package is installing
# cuda for the first time (nvcc path will be in $PATH only after relogin)