summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2019-07-15 01:42:13 +0000
committerDaniel Bermond2019-07-15 01:42:13 +0000
commit0520740e8f263389d259545a742e7f6c114af8aa (patch)
tree21ddc674c0ae6535debca1cce5c11ff817a6f59a /PKGBUILD
parentf3c3bfd75f8e605b8c54620f03dc23a726b3eaaf (diff)
downloadaur-0520740e8f263389d259545a742e7f6c114af8aa.tar.gz
Drop i686 support
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8afe260ace3f..7bf4d57712df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,10 @@
# Contributor: DrZaius <lou at fakeoutdoorsman.com>
pkgname=ffmpeg-git
-_srcname=ffmpeg
-pkgver=4.2.r92486.g8f875a90c4
+pkgver=4.2.r94300.gaf5f770113
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (git version)'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='https://www.ffmpeg.org/'
license=('GPL3')
depends=('alsa-lib' 'aom' 'bzip2' 'fontconfig' 'fribidi' 'glibc' 'gmp' 'gnutls' 'gsm'
@@ -29,13 +28,13 @@ source=('git+https://git.ffmpeg.org/ffmpeg.git')
sha256sums=('SKIP')
pkgver() {
- cd "$_srcname"
+ cd ffmpeg
local _version
local _revision
local _shorthash
- _version="$( git describe --tags --long | awk -F'-' '{ printf $1 }' | sed 's/^n//')"
+ _version="$( git describe --tags --long | awk -F'-' '{ sub(/^n/, "", $1); print $1 }')"
_revision="$( git describe --tags --match 'N' | awk -F'-' '{ printf $2 }')"
_shorthash="$(git rev-parse --short HEAD)"
@@ -43,7 +42,7 @@ pkgver() {
}
build() {
- cd "$_srcname"
+ cd ffmpeg
printf '%s\n' ' -> Running ffmpeg configure script...'
@@ -98,7 +97,7 @@ build() {
}
package() {
- cd "$_srcname"
+ cd ffmpeg
make DESTDIR="$pkgdir" install