summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKamran Mackey2016-07-04 16:44:21 -0600
committerKamran Mackey2016-07-04 16:44:21 -0600
commit4c776aaf1e9d1ef2cd9a962be7a3a9cc730e2000 (patch)
treef2be70089789b4e90a09059c34f704168ced44cd /PKGBUILD
parent34d726bbdaee32d41ab2ca652b8407a21d5b2d64 (diff)
downloadaur-4c776aaf1e9d1ef2cd9a962be7a3a9cc730e2000.tar.gz
Major update!
Revamped pkgver(), removed broken build options and removed dependencies that are no longer needed. Signed-off-by: Kamran Mackey <kamranm1200@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 85c102673636..623c0e567295 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,27 +9,28 @@ pkgdesc="Complete solution to record, convert and stream audio and video (git ve
arch=('i686' 'x86_64')
license=('GPL3')
url="http://ffmpeg.org/"
-depends=(
- 'alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'gnutls' 'gsm' 'lame' 'libass'
- 'libbluray' 'libmodplug' 'libpulse' 'libsoxr' 'libssh' 'libtheora'
- 'libva' 'libvdpau' 'libwebp' 'opencore-amr' 'openjpeg' 'opus'
- 'schroedinger' 'sdl' 'speex' 'v4l-utils' 'xvidcore' 'zlib'
- 'libvidstab.so' 'libvorbis.so' 'libvorbisenc.so' 'libvpx.so'
- 'libx264.so' 'libx265.so' 'libfdk-aac')
+depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'gmp' 'gnutls' 'gsm' 'lame'
+ 'libass' 'libavc1394' 'libbluray' 'libiec61883' 'libmodplug' 'libpulse'
+ 'libsoxr' 'libssh' 'libtheora' 'libva' 'libvdpau' 'libwebp'
+ 'netcdf' 'opencore-amr' 'openjpeg' 'opus' 'schroedinger' 'sdl' 'speex'
+ 'v4l-utils' 'xvidcore' 'zlib'
+ 'libvidstab.so' 'libvorbis.so' 'libvorbisenc.so' 'libvpx.so'
+ 'libx264.so' 'libx265.so')
makedepends=('hardening-wrapper' 'ladspa' 'libvdpau' 'yasm')
optdepends=('ladspa: LADSPA filters')
-provides=(
- 'libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
- 'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
- 'libswscale.so' 'ffmpeg'
-)
+provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
+ 'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
+ 'libswscale.so')
conflicts=('ffmpeg' 'ffmpeg-full-git')
source=("$pkgname"::'git://source.ffmpeg.org/ffmpeg.git')
md5sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ _ver="$(git describe --tags | sed 's|-[^-]*$||' | sed 's|^n||')"
+ _rev="$(git rev-list --count HEAD)"
+ _gitid="$(git rev-parse --short HEAD)"
+ echo "${_ver}.r${_rev}.g${_gitid}"
}
build() {
@@ -47,7 +48,6 @@ build() {
--enable-ladspa \
--enable-libass \
--enable-libbluray \
- --enable-libdcadec \
--enable-libfdk-aac \
--enable-libfreetype \
--enable-libfribidi \