summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2024-05-01 13:33:02 -0300
committerDaniel Bermond2024-05-01 13:33:02 -0300
commit58984b2fb685c3d8e66bced5a2fb9b23333e24ea (patch)
tree57e722d97a18aab0cc797799351a97b06df3acef /PKGBUILD
parent54cee0fbe3aef0316dbb554d87f389149ecccae7 (diff)
downloadaur-58984b2fb685c3d8e66bced5a2fb9b23333e24ea.tar.gz
Fix nvidia vulkan decoding segmentation fault
Original patch for fixing nvidia vulkan decoding: https://github.com/streetpea/chiaki4deck/issues/239#issuecomment-1929365254 References ---------- [1] https://trac.ffmpeg.org/ticket/10847 [2] https://trac.ffmpeg.org/ticket/10970
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e17ed123ceab..963c49a7fb41 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,12 @@
# Contributor: DrZaius <lou at fakeoutdoorsman.com>
pkgname=ffmpeg-git
-pkgver=6.1.r112534.ge5f774268a
+pkgver=7.1.r115041.ge757726e89
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (git version)'
arch=('x86_64')
url='https://www.ffmpeg.org/'
-license=('GPL3')
+license=('GPL-3.0-or-later')
depends=(
alsa-lib
aom
@@ -95,14 +95,17 @@ provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
conflicts=('ffmpeg')
source=('git+https://git.ffmpeg.org/ffmpeg.git'
'040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch'
- '060-ffmpeg-fix-segfault-with-avisynthplus.patch')
+ '050-ffmpeg-fix-segfault-with-avisynthplus.patch'
+ '060-ffmpeg-fix-nvidia-vulkan-decoding-segfault.patch')
sha256sums=('SKIP'
- '9b94b90a33dc8ac9693d72c825e9c444df914428fce7cca61117146ee8f8c07b'
- '0e277c0d5e33612ca7a11025958133b17bfbe23168b0aee5bd07f674f6fd7440')
+ 'b54b47f4f3837ddc41227bd2202ea3c62e2ddb06c6cfbd7a9adc304d641d79ba'
+ '0e277c0d5e33612ca7a11025958133b17bfbe23168b0aee5bd07f674f6fd7440'
+ 'f2f73793a45c9dffb033f23c1b10a612abe6528cbd06c04b06e8189d1ef208be')
prepare() {
patch -d ffmpeg -Np1 -i "${srcdir}/040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch"
- patch -d ffmpeg -Np1 -i "${srcdir}/060-ffmpeg-fix-segfault-with-avisynthplus.patch"
+ patch -d ffmpeg -Np1 -i "${srcdir}/050-ffmpeg-fix-segfault-with-avisynthplus.patch"
+ patch -d ffmpeg -Np1 -i "${srcdir}/060-ffmpeg-fix-nvidia-vulkan-decoding-segfault.patch"
}
pkgver() {