summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2018-05-02 17:30:16 +0000
committerDaniel Bermond2018-05-02 17:30:16 +0000
commit70efbb43ced05e599388c523bcf7a0a37ee09b39 (patch)
treed56ae852a8556fdde5381a05a9bf99d0c258eb5c /PKGBUILD
parentb3584525a90de1beb9aaae79046182d43da38795 (diff)
downloadaur-70efbb43ced05e599388c523bcf7a0a37ee09b39.tar.gz
Add --enable-omx to match official repository package
References ---------- https://git.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/ffmpeg&id=ea3d2c484f7184e70213196e0feeece5a0fb4444
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cf1cd9fa79c9..45080bf5b9e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: DrZaius <lou at fakeoutdoorsman.com>
pkgname=ffmpeg-git
-pkgver=3.5.r89688.g1b283c4a0d
+pkgver=4.1.r90921.ga150b2e3a0
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (git version)'
arch=('i686' 'x86_64')
@@ -15,6 +15,7 @@ depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'glibc' 'gmp' 'gnutls' 'gsm'
'libraw1394' 'libsoxr' 'libssh' 'libtheora' 'libvdpau' 'libwebp'
'libx11' 'libxcb' 'libxml2' 'opencore-amr' 'openjpeg2' 'opus' 'sdl2'
'speex' 'v4l-utils' 'xz' 'zlib'
+ 'libomxil-bellagio'
'libass.so' 'libbluray.so' 'libfreetype.so' 'libva-drm.so' 'libva.so'
'libva-x11.so' 'libvidstab.so' 'libvorbisenc.so' 'libvorbis.so'
'libvpx.so' 'libx264.so' 'libx265.so' 'libxvidcore.so')
@@ -31,9 +32,11 @@ sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
- local _version="$( git describe --tags --long | cut -d'-' -f1 | sed 's/^n//')"
- local _revision="$( git describe --tags --match 'N' | cut -d'-' -f2)"
+
+ local _version="$( git describe --tags --long | awk -F'-' '{ printf $1 }' | sed 's/^n//')"
+ local _revision="$( git describe --tags --match 'N' | awk -F'-' '{ printf $2 }')"
local _shorthash="$(git rev-parse --short HEAD)"
+
printf '%s.r%s.g%s' "$_version" "$_revision" "$_shorthash"
}
@@ -82,13 +85,17 @@ build() {
--enable-libxml2 \
--enable-libxvid \
--enable-shared \
- --enable-version3
+ --enable-version3 \
+ --enable-omx
+
make
make tools/qt-faststart
}
package() {
cd "$pkgname"
+
make DESTDIR="$pkgdir" install
+
install -D -m755 tools/qt-faststart "${pkgdir}/usr/bin/qt-faststart"
}