summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKamran Mackey2015-12-20 12:54:13 -0700
committerKamran Mackey2015-12-20 12:54:13 -0700
commita2f77d69fb752b8af728db720898c0dc9816e8b3 (patch)
tree7677bf82de7e226bad457c176c764227714a708d /PKGBUILD
parent636aee36df20cdf0f64059640d10a8db0ed0feb9 (diff)
downloadaur-a2f77d69fb752b8af728db720898c0dc9816e8b3.tar.gz
Go back to being lean.
Signed-off-by: Kamran Mackey <kamranm1200@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD59
1 files changed, 7 insertions, 52 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1bcb742faa3c..8287e5492ff1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: DrZaius <lou at fakeoutdoorsman.com>
pkgname=ffmpeg-git
-pkgver=r77407.f6830cf
+pkgver=r77411.9e569ab
pkgrel=1
pkgdesc="Complete solution to record, convert and stream audio and video (git version)"
arch=('i686' 'x86_64')
@@ -15,14 +15,7 @@ depends=(
'libva' 'libvdpau' 'libwebp' 'opencore-amr' 'openjpeg' 'opus'
'schroedinger' 'sdl' 'speex' 'v4l-utils' 'xvidcore' 'zlib'
'libdcadec.so' 'libvidstab.so' 'libvorbis.so' 'libvorbisenc.so'
- 'libvpx.so' 'libx264.so' 'libx265.so'
- 'celt' 'faac' 'frei0r-plugins' 'jack' 'ladspa' 'libaacplus'
- 'libavc1394' 'libbs2b' 'libcaca' 'libcdio-paranoia' 'libcl' 'libdc1394'
- 'libfdk-aac' 'libgme' 'libiec61883' 'libutvideo-git'
- 'libxv' 'mesa' 'openal' 'opencl-headers' 'openh264'
- 'rtmpdump' 'shine' 'snappy' 'twolame' 'vid.stab'
- 'vo-aacenc' 'vo-amrwbenc' 'wavpack' 'xavs' 'zeromq' 'zvbi'
-)
+ 'libvpx.so' 'libx264.so' 'libx265.so')
makedepends=('hardening-wrapper' 'ladspa' 'libvdpau' 'yasm')
optdepends=('ladspa: LADSPA filters')
provides=(
@@ -46,80 +39,42 @@ build() {
--prefix=/usr \
--disable-debug \
--disable-static \
- --enable-shared \
--enable-avisynth \
--enable-avresample \
- --enable-decoder=atrac3 \
- --enable-decoder=atrac3p \
- --enable-dxva2 \
--enable-fontconfig \
- --enable-frei0r \
--enable-gnutls \
--enable-gpl \
- --enable-gray \
--enable-ladspa \
- --enable-libaacplus \
--enable-libass \
--enable-libbluray \
--enable-libdcadec \
- --enable-libbs2b \
- --enable-libcaca \
- --enable-libcdio \
- --enable-libcelt \
- --enable-libdc1394 \
- --enable-libfaac \
- --enable-libfdk-aac \
--enable-libfreetype \
--enable-libfribidi \
- --enable-libgme \
--enable-libgsm \
- --enable-libiec61883 \
--enable-libmodplug \
--enable-libmp3lame \
- --enable-libopencore-amrnb \
- --enable-libopencore-amrwb \
- --enable-libopencv \
- --enable-libopenh264 \
+ --enable-libopencore_amrnb \
+ --enable-libopencore_amrwb \
--enable-libopenjpeg \
--enable-libopus \
--enable-libpulse \
- --enable-librtmp \
--enable-libschroedinger \
- --enable-libshine \
- --enable-libsnappy \
--enable-libsoxr \
--enable-libspeex \
--enable-libssh \
--enable-libtheora \
- --enable-libtwolame \
- --enable-libutvideo \
--enable-libv4l2 \
--enable-libvidstab \
- --enable-libvo-aacenc \
- --enable-libvo-amrwbenc \
--enable-libvorbis \
--enable-libvpx \
- --enable-libwavpack \
--enable-libwebp \
--enable-libx264 \
--enable-libx265 \
- --enable-libxavs \
- --enable-libxcb \
- --enable-libxcb-shm \
- --enable-libxcb-xfixes \
- --enable-libxcb-shape \
--enable-libxvid \
- --enable-libzmq \
- --enable-libzvbi \
--enable-nonfree \
- --enable-openal \
- --enable-opencl \
- --enable-opengl \
- --enable-openssl \
- --enable-runtime-cpudetect \
- --enable-swresample \
- --enable-vdpau \
- --enable-version3
+ --enable-shared \
+ --enable-version3 \
+ --enable-x11grab \
make
make tools/qt-faststart