summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Tobias2017-08-03 22:37:44 +1000
committerDaniel Tobias2017-08-03 22:37:44 +1000
commit4816c6982484e6b02f7d6525aa8e92d08c0d59ce (patch)
tree7ee7e68070818f6832b734dba46e0036f43127c4 /PKGBUILD
parent2ea1c94daf0fcd756b75a938920e756684af1ee9 (diff)
downloadaur-4816c6982484e6b02f7d6525aa8e92d08c0d59ce.tar.gz
tabs to spaces, reoder options to match extra
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD116
1 files changed, 61 insertions, 55 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4cdeef94e75a..304b0369da3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,73 +13,79 @@ epoch=1
pkgdesc='Complete solution to record, convert and stream audio and video; optimised for server (headless) systems'
arch=('i686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url='http://ffmpeg.org/'
-license=('GPL3') #enabling libfdk_aac makes ffmpeg incompatible with the GPL!
+license=('GPL3')
depends=('bzip2' 'fribidi' 'glibc' 'gmp' 'gnutls' 'gsm'
- 'lame' 'libmodplug'
- 'libtheora' 'libva-headless'
- 'libwebp' 'opencore-amr' 'openjpeg2' 'opus'
- 'schroedinger' 'speex' 'v4l-utils' 'xz' 'zlib'
- 'libbluray.so'
- 'libvorbisenc.so' 'libvorbis.so' 'libvpx.so'
- 'libx264.so' 'libx265.so' 'libxvidcore.so'
- 'rtmpdump')
+ 'lame' 'libmodplug'
+ 'libtheora' 'libva-headless'
+ 'libwebp' 'opencore-amr' 'openjpeg2' 'opus'
+ 'schroedinger' 'speex' 'v4l-utils' 'xz' 'zlib'
+ 'libbluray.so'
+ 'libvorbisenc.so' 'libvorbis.so' 'libvpx.so'
+ 'libx264.so' 'libx265.so' 'libxvidcore.so'
+ 'rtmpdump')
makedepends=('yasm')
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
'libswscale.so' "ffmpeg")
conflicts=('ffmpeg')
replaces=('ffmpeg')
-source=(https://ffmpeg.org/releases/${_pkgname}-${pkgver}.tar.xz)
+source=("https://ffmpeg.org/releases/${_pkgname}-${pkgver}.tar.xz")
+#validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
sha256sums=('1998de1ab32616cbf2ff86efc3f1f26e76805ec5dc51e24c041c79edd8262785')
build() {
cd ${_pkgname}-${pkgver}
./configure \
- --prefix='/usr' \
- --disable-debug \
- --disable-static \
- --disable-stripping \
- --enable-avisynth \
- --enable-avresample \
- --enable-gnutls \
- --enable-gpl \
- --enable-libbluray \
- --enable-libfribidi \
- --enable-libgsm \
- --enable-libmodplug \
- --enable-libmp3lame \
- --enable-libopencore_amrnb \
- --enable-libopencore_amrwb \
- --enable-libopenjpeg \
- --enable-libopus \
- --enable-libschroedinger \
- --enable-libspeex \
- --enable-libtheora \
- --enable-libv4l2 \
- --enable-libvorbis \
- --enable-libvpx \
- --enable-libwebp \
- --enable-libx264 \
- --enable-libx265 \
- --enable-libxvid \
- --enable-shared \
- --enable-vaapi \
- --enable-version3 \
- --enable-librtmp \
- --enable-runtime-cpudetect \
- --disable-ffplay \
- --disable-sdl2 \
- --disable-fontconfig \
- --disable-libfreetype \
- --disable-vdpau \
- --disable-htmlpages \
- --disable-libxcb \
- --disable-xlib \
- --disable-libass #\
- #--enable-libiec61883
- #--enable-libsoxr \
- #--enable-libvidstab \
+ --prefix='/usr' \
+ --disable-debug \
+ --disable-static \
+ --disable-stripping \
+ --enable-avisynth \
+ --enable-avresample \
+ --disable-fontconfig \
+ --enable-gmp \
+ --enable-gnutls \
+ --enable-gpl \
+ --disable-ladspa \
+ --disable-libass \
+ --enable-libbluray \
+ --disable-libfreetype \
+ --enable-libfribidi \
+ --enable-libgsm \
+ --disable-libiec61883 \
+ --enable-libmodplug \
+ --enable-libmp3lame \
+ --enable-libopencore_amrnb \
+ --enable-libopencore_amrwb \
+ --enable-libopenjpeg \
+ --enable-libopus \
+ --disable-libpulse \
+ --enable-libschroedinger \
+ --disable-libsoxr \
+ --enable-libspeex \
+ --disable-libssh \
+ --enable-libtheora \
+ --enable-libv4l2 \
+ --disable-libvidstab \
+ --enable-libvorbis \
+ --enable-libvpx \
+ --enable-libwebp \
+ --enable-libx264 \
+ --enable-libx265 \
+ --disable-libxcb \
+ --enable-libxvid \
+ --enable-shared \
+ --enable-version3 \
+ --enable-vaapi \
+ --enable-librtmp \
+ --enable-runtime-cpudetect \
+ --disable-vdpau \
+ --disable-xlib \
+ --disable-sdl2 \
+ --disable-htmlpages \
+ --disable-ffplay #\
+ # enabling libfdk_aac makes ffmpeg incompatible with the GPL!
#--enable-libfdk_aac \
#--enable-nonfree
@@ -88,5 +94,5 @@ build() {
package() {
cd ${_pkgname}-${pkgver}
- make DESTDIR="${pkgdir}" install
+ make DESTDIR="${pkgdir}" install install-man
}