summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLaura Hausmann2024-03-19 21:02:11 +0100
committerLaura Hausmann2024-03-19 21:02:11 +0100
commit04675589de7349f5c48582f7980a0826624e849a (patch)
tree50f5ca3d756e8be6930d52f90237a4eea56f6ab9 /PKGBUILD
parent49de98b002c6828ae18dff9214d2699bc08f2a6f (diff)
downloadaur-04675589de7349f5c48582f7980a0826624e849a.tar.gz
Update to 2:6.1.1-7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD125
1 files changed, 83 insertions, 42 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 59e94dd90a6a..7a3d1b8a35d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Ben Widawsky <ben@bwidawsk.net>
+# Maintainer: Laura Hausmann <aur@zotan.email>
+# Contributor: Ben Widawsky <ben@bwidawsk.net>
# Contributor: Rob McCathie <korrode at gmail>
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
@@ -6,77 +7,81 @@
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
# Contributor: Paul Mattal <paul@archlinux.org>
-_name=ffmpeg
pkgname=ffmpeg-libfdk_aac
-pkgver=6.0
-pkgrel=3
-epoch=1
+pkgver=6.1.1
+pkgrel=7
+epoch=2
pkgdesc='Complete solution to record, convert and stream audio and video (Same as official package except with libfdk-aac support)'
arch=(x86_64)
-url=https://ffmpeg.org/
-license=(GPL3 custom:libfdk-aac)
+url=https://ffmpeg.org
+license=(GPL-3.0-only custom:libfdk-aac)
+conflicts=("ffmpeg")
depends=(
alsa-lib
aom
bzip2
+ cairo
+ dav1d
fontconfig
+ freetype2
fribidi
+ glib2
+ glibc
gmp
-# gnutls - https://aur.archlinux.org/packages/ffmpeg-libfdk_aac/#comment-722966
+ gnutls
gsm
+ harfbuzz
jack
lame
- libass.so
+ libass
libavc1394
- libbluray.so
- libbs2b.so
- libdav1d.so
+ libbluray
+ libbs2b
libdrm
- libfreetype.so
libgl
libiec61883
- libjxl.so
+ libjxl
libmodplug
- libopenmpt.so
+ libopenmpt
+ libplacebo
libpulse
- librav1e.so
libraw1394
- librsvg-2.so
+ librsvg
libsoxr
libssh
libtheora
- libva.so
- libva-drm.so
- libva-x11.so
+ libva
libvdpau
- libvidstab.so
- libvorbisenc.so
- libvorbis.so
- libvpx.so
+ libvorbis
+ libvpx
libwebp
libx11
- libx264.so
- libx265.so
libxcb
libxext
libxml2
libxv
- libxvidcore.so
- libzimg.so
ocl-icd
onevpl
opencore-amr
openjpeg2
- openssl # https://aur.archlinux.org/packages/ffmpeg-libfdk_aac/#comment-722966
opus
+ rav1e
+ rubberband
sdl2
+ snappy
speex
srt
svt-av1
v4l-utils
+ vapoursynth
+ vid.stab
vmaf
vulkan-icd-loader
+ x264
+ x265
+ xvidcore
xz
+ zimg
zlib
libfdk-aac
)
@@ -85,6 +90,7 @@ makedepends=(
avisynthplus
clang
ffnvcodec-headers
+ frei0r-plugins
git
ladspa
mesa
@@ -94,12 +100,14 @@ makedepends=(
)
optdepends=(
'avisynthplus: AviSynthPlus support'
- 'intel-media-sdk: Intel QuickSync support'
- 'onevpl-intel-gpu: Intel QuickSync support'
+ 'frei0r-plugins: Frei0r video effects support'
+ 'intel-media-sdk: Intel QuickSync support (legacy)'
'ladspa: LADSPA filters'
'nvidia-utils: Nvidia NVDEC/NVENC support'
+ 'onevpl-intel-gpu: Intel QuickSync support'
)
provides=(
+ ffmpeg
libavcodec.so
libavdevice.so
libavfilter.so
@@ -108,18 +116,16 @@ provides=(
libpostproc.so
libswresample.so
libswscale.so
- "ffmpeg=$pkgver"
)
options=(
debug
)
-conflicts=("$_name")
-_tag=3949db4d261748a9f34358a388ee255ad1a7f0c0
+_tag=6f4048827982a8f48f71f551a6e1ed2362816eec
source=(
git+https://git.ffmpeg.org/ffmpeg.git?signed#tag=${_tag}
add-av_stream_get_first_dts-for-chromium.patch
)
-b2sums=('SKIP'
+b2sums=('9c19bd6b68d4224af2a93fdce199fd0ce9b00432c8818801d124ca993ac45a01d3a7618b66804c02c1f26787a5ca88d2d9f682f3e819cee8c2b6b3dc77e64052'
'555274228e09a233d92beb365d413ff5c718a782008075552cafb2130a3783cf976b51dfe4513c15777fb6e8397a34122d475080f2c4483e8feea5c0d878e6de')
validpgpkeys=(DD1EC9E8DE085C629B3E1846B18E8928B3948D64) # Michael Niedermayer <michael@niedermayer.cc>
@@ -133,6 +139,13 @@ prepare() {
# use non-deprecated nvenc GUID for conftest
git cherry-pick -n 03823ac0c6a38bd6ba972539e3203a592579792f
git cherry-pick -n d2b46c1ef768bc31ba9180f6d469d5b8be677500
+ # Fix VDPAU vo
+ git cherry-pick -n e9c93009fc34ca9dfcf0c6f2ed90ef1df298abf7
+ # Fix bug in av_fft_end
+ git cherry-pick -n a562cfee2e214252f8b3f516527272ae32ef9532
+ git cherry-pick -n 250471ea1745fc703eb346a2a662304536a311b1
+ # Fix build with latest vulkan headers
+ git cherry-pick -n fef22c87ada4517441701e6e61e062c9f4399c8e
}
pkgver() {
@@ -152,7 +165,9 @@ build() {
--enable-cuda-llvm \
--enable-lto \
--enable-fontconfig \
+ --enable-frei0r \
--enable-gmp \
+ --enable-gnutls \
--enable-gpl \
--enable-ladspa \
--enable-libaom \
@@ -164,6 +179,7 @@ build() {
--enable-libfreetype \
--enable-libfribidi \
--enable-libgsm \
+ --enable-libharfbuzz \
--enable-libiec61883 \
--enable-libjack \
--enable-libjxl \
@@ -174,9 +190,12 @@ build() {
--enable-libopenjpeg \
--enable-libopenmpt \
--enable-libopus \
+ --enable-libplacebo \
--enable-libpulse \
--enable-librav1e \
--enable-librsvg \
+ --enable-librubberband \
+ --enable-libsnappy \
--enable-libsoxr \
--enable-libspeex \
--enable-libsrt \
@@ -200,16 +219,12 @@ build() {
--enable-nvenc \
--enable-opencl \
--enable-opengl \
- --enable-openssl \
--enable-shared \
- --enable-vaapi \
+ --enable-vapoursynth \
--enable-version3 \
--enable-vulkan \
- --enable-libfdk_aac \
- --enable-nonfree \
- --disable-htmlpages
-# --enable-gnutls https://aur.archlinux.org/packages/ffmpeg-libfdk_aac/#comment-722966
-
+ --enable-libfdk-aac \
+ --enable-nonfree
make
make tools/qt-faststart
make doc/ff{mpeg,play}.1
@@ -218,6 +233,32 @@ build() {
}
package() {
+ depends+=(
+ libass.so
+ libbluray.so
+ libbs2b.so
+ libdav1d.so
+ libfreetype.so
+ libharfbuzz.so
+ libjxl.so
+ libopenmpt.so
+ libplacebo.so
+ librav1e.so
+ librsvg-2.so
+ librubberband.so
+ libva.so
+ libva-drm.so
+ libva-x11.so
+ libvidstab.so
+ libvorbisenc.so
+ libvorbis.so
+ libvpx.so
+ libx264.so
+ libx265.so
+ libxvidcore.so
+ libzimg.so
+ )
+
make DESTDIR="${pkgdir}" -C ffmpeg install install-man
install -Dm 755 ffmpeg/tools/qt-faststart "${pkgdir}"/usr/bin/