summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBen Widawsky2015-07-30 20:32:33 -0700
committerBen Widawsky2015-07-30 20:32:33 -0700
commit74aed2194f5ee8c39dc6ad6c120420e408557b11 (patch)
tree1567cf339c1d94e3173e2631bafe51a6c4b09597 /PKGBUILD
parent477ef45b543c372e50a81e63dcd67e6f7fe692e0 (diff)
downloadaur-74aed2194f5ee8c39dc6ad6c120420e408557b11.tar.gz
Update to latest upstream package
This commit actually merges together a few things from the upstream Arch build. Ideally, I would split it out, but I doubt anyone would notice or care in this case.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 19 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9f1b85c32934..cdd9022676ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,26 +8,32 @@
_name=ffmpeg
pkgname=ffmpeg-libfdk_aac
-pkgver=2.7.1
-pkgrel=3
+pkgver=2.7.2
+pkgrel=1
epoch=1
-pkgdesc="Complete and free Internet live audio and video broadcasting solution (Same as official package except with libfdk-aac support)"
+pkgdesc='Complete solution to record, convert and stream audio and video (Same as official package except with libfdk-aac support)'
arch=('i686' 'x86_64')
url='http://ffmpeg.org/'
license=('GPL3' 'custom')
depends=(
- 'alsa-lib' 'bzip2' 'fontconfig' 'gnutls' 'gsm' 'lame' 'libass' 'libvdpau'
- 'libbluray' 'libmodplug' 'libpulse' 'libtheora' 'libva' 'libwebp'
- 'opencore-amr' 'openjpeg' 'opus' 'schroedinger' 'sdl' 'speex' 'v4l-utils'
- 'xvidcore' 'zlib' 'fribidi' 'libssh'
- 'libvorbisenc.so' 'libvorbis.so' 'libvpx.so' 'libx264.so' 'libx265.so'
+ 'alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'gnutls' 'gsm' 'lame' 'libass'
+ 'libbluray' 'libmodplug' 'libpulse' 'libsoxr' 'libssh' 'libtheora'
+ 'libva' 'libvdpau' 'libwebp' 'opencore-amr' 'openjpeg' 'opus'
+ 'schroedinger' 'sdl' 'speex' 'v4l-utils' 'xvidcore' 'zlib'
+ 'libvorbis.so' 'libvorbisenc.so' 'libvpx.so' 'libx264.so' 'libx265.so'
'libfdk-aac'
)
-makedepends=('libvdpau' 'yasm' 'hardening-wrapper')
+makedepends=('hardening-wrapper' 'libvdpau' 'yasm')
+provides=(
+ 'libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
+ 'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
+ 'libswscale.so'
+)
conflicts=("$_name")
-provides=("$_name=$pkgver" "qt-faststart")
-source=(http://ffmpeg.org/releases/$_name-$pkgver.tar.bz2)
-md5sums=('f159c6d7eed8546b23e1a17325cbf1f8')
+source=(http://ffmpeg.org/releases/$_name-$pkgver.tar.bz2{,.asc})
+validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8') # ffmpeg-devel
+md5sums=('7eb2140bab9f0a8669b65b50c8e4cfb5'
+ 'SKIP')
build() {
cd $_name-$pkgver
@@ -55,6 +61,7 @@ build() {
--enable-libopus \
--enable-libpulse \
--enable-libschroedinger \
+ --enable-libsoxr \
--enable-libspeex \
--enable-libssh \
--enable-libtheora \