summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBen Widawsky2021-03-17 08:55:15 -0700
committerBen Widawsky2021-03-17 08:55:15 -0700
commitc4ef89557620dba9ab4dab022862da35fe33b29a (patch)
treeecb569648092dbabc5a43a52dc6d95eeba63f761 /PKGBUILD
parent259fe3e6f05e66b90a2f3e154d61df03f4c1f9cd (diff)
downloadaur-c4ef89557620dba9ab4dab022862da35fe33b29a.tar.gz
upgpkg: 4.3.2-1: new upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4db36922827d..586788bd83bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@
_name=ffmpeg
pkgname=ffmpeg-libfdk_aac
-pkgver=4.3.1
-pkgrel=3
+pkgver=4.3.2
+pkgrel=1
epoch=1
pkgdesc='Complete solution to record, convert and stream audio and video (Same as official package except with libfdk-aac support)'
arch=(x86_64)
@@ -58,6 +58,7 @@ depends=(
libxml2
libxv
libxvidcore.so
+ libzimg.so
opencore-amr
openjpeg2
openssl # https://aur.archlinux.org/packages/ffmpeg-libfdk_aac/#comment-722966
@@ -97,7 +98,7 @@ provides=(
libswscale.so
"ffmpeg=$pkgver"
)
-_tag=6b6b9e593dd4d3aaf75f48d40a13ef03bdef9fdb
+_tag=f719f869907764e6412a6af6e178c46e5f915d25
conflicts=("$_name")
source=(
git+https://git.ffmpeg.org/ffmpeg.git#tag=${_tag}
@@ -115,8 +116,9 @@ prepare() {
cd ffmpeg
git cherry-pick -n 7c59e1b0f285cd7c7b35fcd71f49c5fd52cf9315 # fix build against libsrt 1.4.2
- patch -Np1 -i "${srcdir}"/vmaf-model-path.patch
+ patch -Np1 -i "${srcdir}"/vmaf-model-path.patch
}
+
build() {
cd ffmpeg
@@ -168,9 +170,9 @@ build() {
--enable-libxcb \
--enable-libxml2 \
--enable-libxvid \
+ --enable-libzimg \
--enable-nvdec \
--enable-nvenc \
- --enable-omx \
--enable-openssl \
--enable-shared \
--enable-version3 \