summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrédéric Mangano-Tarumi2020-01-05 20:00:00 -0500
committerFrédéric Mangano-Tarumi2020-01-05 20:00:00 -0500
commit2f97fa0b97598f969ef0f311b299b4c9ddcc0843 (patch)
treeaa556fabb7697df03945dfb332cf00ca087ef62d /PKGBUILD
parent63292693f59162fde4896b6253eacbbaf4474f3a (diff)
downloadaur-2f97fa0b97598f969ef0f311b299b4c9ddcc0843.tar.gz
ffmpeg 4.2.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 17 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b85adc4c73b1..ebceabdd872f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,8 @@
# Upstream: https://raw.githubusercontent.com/archlinuxarm/PKGBUILDs/master/extra/ffmpeg/PKGBUILD
pkgname=ffmpeg-mmal
-pkgver=4.2
+_gitcommit=cbb3c9497549f8856d8cd37ac63af1406a784e58
+pkgver=4.2.1
pkgrel=1
epoch=1
pkgdesc='ffmpeg built with MMAL hardware acceleration support for Raspberry Pi'
@@ -87,9 +88,21 @@ provides=(
libswresample.so
libswscale.so
)
-source=(git+https://git.ffmpeg.org/ffmpeg.git#tag=n${pkgver})
conflicts=('ffmpeg')
-sha256sums=('SKIP')
+source=("git+https://git.ffmpeg.org/ffmpeg.git#commit=${_gitcommit}")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd ffmpeg
+
+ git describe --tags | sed 's/^n//'
+}
+
+prepare() {
+ cd ffmpeg
+
+ git cherry-pick -n dc0806dd25882f41f6085c8356712f95fded56c7
+}
build() {
cd ffmpeg
@@ -97,7 +110,7 @@ build() {
[[ $CARCH == "armv7h" || $CARCH == "aarch64" ]] && CONFIG='--host-cflags="-fPIC"'
./configure \
- --prefix='/usr' \
+ --prefix=/usr \
--disable-debug \
--disable-static \
--disable-stripping \