summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122020-08-30 10:33:38 +0200
committerwillemw122020-08-30 10:33:38 +0200
commita9e3b2e85fffa76ea52f82695066e2fdc17d1407 (patch)
tree0ec4a3094e76b8e4abe61ea37fd5907c4615d15a /PKGBUILD
downloadaur-a9e3b2e85fffa76ea52f82695066e2fdc17d1407.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54fc6d2f2130
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: willemw <willemw12@gmail.com>
+
+pkgname=ffmpeg-normalize-git
+pkgver=1.20.1.r2.gbc0fbb3
+pkgrel=1
+pkgdesc="Audio normalization for Python/FFmpeg"
+arch=('any')
+url="https://github.com/slhck/ffmpeg-normalize"
+license=('MIT')
+depends=('ffmpeg' 'python-colorama' 'python-tqdm')
+makedepends=('git' 'python-setuptools')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $pkgname
+ python setup.py build
+}
+
+check() {
+ cd $pkgname
+ python test/test.py
+}
+
+package() {
+ cd $pkgname
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}