summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederic Bezies2017-04-14 16:51:27 +0200
committerFrederic Bezies2017-04-14 16:51:27 +0200
commita60aa6bee6a6b20c3aa9b9bee62581e1b44d9832 (patch)
treee22492b121a19e0a24e8b82562d69547acaaad12 /PKGBUILD
parent1ea2b634e668eada4a45b17aad0e6b4e50d17485 (diff)
downloadaur-a60aa6bee6a6b20c3aa9b9bee62581e1b44d9832.tar.gz
ffmpeg 3.3 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aa2e535a166d..116f227f9551 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@
# Contributor: Paul Mattal <paul@archlinux.org>
pkgname=ffmpeg-nvenc
-pkgver=3.2.4
-pkgrel=2
+pkgver=3.3
+pkgrel=1
epoch=1
pkgdesc='Complete solution to record, convert and stream audio and video with Nvidia CUDA Hardware Acceleration'
arch=('x86_64')
@@ -21,14 +21,14 @@ depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'gmp' 'gnutls' 'gsm' 'lame'
'v4l-utils' 'xvidcore' 'zlib' 'cuda' 'nvidia-sdk'
'nvidia' 'libvidstab.so' 'libvorbis.so' 'libvorbisenc.so' 'libvpx.so'
'libx264.so' 'libx265.so')
-makedepends=('hardening-wrapper' 'ladspa' 'libvdpau' 'yasm')
+makedepends=('hardening-wrapper' 'ladspa' 'libvdpau' 'yasm' 'jre8-openjdk')
optdepends=('ladspa: LADSPA filters')
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
'libswscale.so' 'ffmpeg')
conflicts=('ffmpeg' 'ffmpeg-full-nvenc' 'ffmpeg-nvenc-manjaro')
source=(http://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.bz2)
-sha256sums=('c0fa3593a2e9e96ace3c1757900094437ad96d1d6ca19f057c378b5f394496a4')
+sha256sums=('21e08647c9e740a4d3b85bf455b31d079fe0faba9555fa9329230e8541cf6bdc')
build() {
cd ffmpeg-${pkgver}
@@ -77,7 +77,6 @@ build() {
--enable-netcdf \
--enable-shared \
--enable-version3 \
- --enable-x11grab \
--extra-cflags="-I/usr/include/nvidia-sdk \
-I/opt/cuda/include \
-I/usr/lib/jvm/$(archlinux-java get)/include \
@@ -101,3 +100,4 @@ package() {
}
# vim: ts=2 sw=2 et:
+