summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWillem Mulder2018-01-19 12:24:14 +0100
committerWillem Mulder2018-01-19 12:24:14 +0100
commita7493414969aeed0673ead2e580bef0797917b15 (patch)
tree003f2e8ddd019ee198df09de0dbdf9f42bf51f62 /PKGBUILD
downloadaur-a7493414969aeed0673ead2e580bef0797917b15.tar.gz
Create package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a59348ba95d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Willem Mulder <14mRh4X0r@gmail.com>
+pkgname=ffmpegfs
+pkgver=0.95
+pkgrel=1
+pkgdesc="FUSE-based transcoding filesystem from many formats to MP3 or MP4 including video transcoding"
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64') # Not arch-specific, should work on all
+url="https://nschlia.github.io/ffmpegfs/"
+license=('GPL3' 'FDL1.3')
+depends=('fuse' 'ffmpeg' 'sqlite3')
+source=("https://github.com/nschlia/ffmpegfs/releases/download/v0.95/ffmpegfs-0.95.tar.gz")
+sha384sums=('d05fc7337a64fe94dde34770c2c696029d2614ac5c8afde521926fc92ec3c85f29f0afd6337a92e2a9914c0905c0ca6b')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+
+ install -Dm644 README.md "$pkgdir/usr/share/doc/ffmpegfs/README.md"
+}