summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorguns2020-02-02 21:48:25 -0600
committerguns2020-02-02 21:59:40 -0600
commit1a38c8b3d2f86007f6cd9a6ec3e7ca52fbc321a5 (patch)
treebd9257838ddbcc7a93d20f8bc2cb3cf1e547c8cb /PKGBUILD
downloadaur-ffox-remote.tar.gz
Add PKGBUILD for ffox-remote
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb1abc5b8561
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Sung Pae <self AT sungpae DOT com>
+pkgname=ffox-remote
+_commit='b936fe94248eb084883211289020e1c1d43f6a71'
+pkgver="20141024.$_commit"
+pkgrel=1
+pkgdesc='Lightweight remote control for Unix Firefox'
+arch=('x86_64')
+url="https://github.com/siebenmann/ffox-remote"
+license=('unknown')
+depends=('glibc')
+makedepends=('go')
+source=("https://github.com/siebenmann/ffox-remote/archive/$_commit.zip")
+sha512sums=('043c5983b21ea59b341a0acfc55e44a6ca9f8c62ec677eca255421cc4891c0385fe75acaa7a53cdc8a559734cd7779fade931cc96fc632c3ece49b43117f7d67')
+
+build() {
+ cd "$pkgname-$_commit"
+ go build -buildmode=pie -o "$pkgname"
+}
+
+package() {
+ cd "$pkgname-$_commit"
+ install -m 0755 -D -t "$pkgdir/usr/bin" "$pkgname"
+}