summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortimvisee2019-04-04 09:57:43 +0000
committertimvisee2019-04-04 09:57:43 +0000
commit8b62b2eae0bab52e89b740668069814424422345 (patch)
treef05553bd58a6618c9920c93ad1f55028d3896a0a /PKGBUILD
parent78268308070c3768487030ac1b1b4fe88d188ab1 (diff)
downloadaur-8b62b2eae0bab52e89b740668069814424422345.tar.gz
Release v0.2.43
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 22 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f8d0ac6652c2..e4af2439edde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,34 @@
# Maintainer: Tim Visee <tim@visee.me>
# Contributor: Ariel AxionL <i at axionl dot me>
+#
+# This PKGBUILD is managed externally, and is automatically updated here:
+# - https://gitlab.com/timvisee/ffsend/blob/master/pkg/aur/ffsend-bin/PKGBUILD
+# - Mirror: https://github.com/timvisee/ffsend/blob/master/pkg/aur/ffsend-bin/PKGBUILD
pkgname=ffsend-bin
-pkgver=0.2.42
-pkgrel=4
+pkgver=0.2.43
+pkgrel=1
pkgdesc="Easily and securely share files from the command line. A Firefox Send client."
-arch=('x86_64')
url="https://gitlab.com/timvisee/ffsend"
license=('GPL3')
-depends=('ca-certificates')
-optdepends=('xclip: clipboard support')
+source=("ffsend-v$pkgver::https://github.com/timvisee/ffsend/releases/download/v0.2.43/ffsend-v0.2.43-linux-x64-static"
+ "ffsend-v$pkgver.bash::https://gitlab.com/timvisee/ffsend/raw/v0.2.43/contrib/completions/ffsend.bash"
+ "ffsend-v$pkgver.fish::https://gitlab.com/timvisee/ffsend/raw/v0.2.43/contrib/completions/ffsend.fish") # automatically set in CI, see: /.gitlab-ci.yml
+sha256sums=('de1fd1348c70e275e949cb297f86db5eccde0523e92a4d35c803a9df2e7857cd' 'bd0f63d4acaed87da9bc80725ec2242c273463cf64ac56c858c46164a6a8a3ab' '15d9a3e79265615a73af4de0e20dd662ad96470aac7fc5dfeff7d26d90bdc667')
+arch=('x86_64')
provides=('ffsend')
-conflicts=('ffsend-git' 'ffsend')
+conflicts=('ffsend')
+depends=('ca-certificates')
+optdepends=('xclip: clipboard support'
+ 'bash-completion: support auto completion for bash')
-source=("ffsend::https://github.com/timvisee/ffsend/releases/download/v${pkgver}/ffsend-v$pkgver-linux-x64-static")
+package() {
+ cd "$srcdir"
-sha256sums=('82bc1dfd553913807b5d850afea5683787f19a46daff2923539cf6ce1038746f')
+ # Install Binary
+ install -Dm755 "ffsend-v$pkgver" "$pkgdir/usr/bin/ffsend"
-package() {
- install -Dm755 "${srcdir}/ffsend" "${pkgdir}/usr/bin/ffsend"
+ # Install completions
+ install -Dm644 "ffsend-v$pkgver.bash" "$pkgver/usr/share/bash-completion/completions/ffsend"
+ install -Dm644 "ffsend-v$pkgver.fish" "$pkgver/usr/share/fish/vendor_completions.d/ffsend.fish"
}