summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortimvisee2019-03-04 14:46:52 +0000
committertimvisee2019-03-04 14:46:52 +0000
commit631873f3d3d33d4eb5ea272d7036733e7ae39a8b (patch)
tree30530a7d3eb99df2ba43ff3329530a878c0d7013 /PKGBUILD
downloadaur-631873f3d3d33d4eb5ea272d7036733e7ae39a8b.tar.gz
Release v0.2.9
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39ac2a0423af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Tim Visee <tim@visee.me>
+
+pkgname=ffsend-git
+pkgver=0.2.9
+pkgrel=1
+pkgdesc="Easily and securely share files from the command line. A Firefox Send client."
+url="https://gitlab.com/timvisee/ffsend"
+license=('GPL3')
+provides=('ffsend=$pkgver')
+conflicts=('ffsend')
+source=("ffsend-v$pkgver.tar.gz::$url/-/archive/v$pkgver/ffsend-v$pkgver.tar.gz")
+sha256sums=('SKIP')
+arch=('x86_64' 'i686')
+depends=('ca-certificates')
+makedepends=('openssl>=1.0' 'rust' 'cargo' 'cmake')
+optdepends=('xclip: clipboard support')
+
+build() {
+ cd "ffsend-v$pkgver"
+ env CARGO_INCREMENTAL=0 cargo build --release
+}
+
+package() {
+ install -Dm755 "$srcdir/ffsend-v$pkgver/target/release/ffsend" "$pkgdir/usr/bin/ffsend"
+}