summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlain2021-04-19 13:48:09 -0700
committerlain2021-04-19 13:48:09 -0700
commit341a58c12fa587a06f7d311441f51c71364a95b2 (patch)
tree23e5e8adbf89426087ec1259e1234c0019b3cd63 /PKGBUILD
parent08c96c7f498dab5ebe9f945a70446be4f4f2c73d (diff)
downloadaur-ffts-git.tar.gz
Add cmake build dependency. Apply fix for non-SSE2 machines.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 19 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 19c0ef011571..9c1d80d41a0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,37 @@
# Maintainer: lain <aur@hacktheinter.net>
pkgname=ffts-git
pkgver=r799.fe86885
-pkgrel=2
+pkgrel=3
pkgdesc="The Fastest Fourier Transform in the South"
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-arch=('i686' 'x86_64' 'arm')
+arch=('any')
url='https://github.com/anthonix/ffts'
-md5sums=('SKIP')
license=('BSD')
depends=()
-makedepends=('git')
-source=('git+https://github.com/anthonix/ffts.git')
+makedepends=('git' 'cmake')
+source=(
+ 'git+https://github.com/anthonix/ffts.git'
+ 'fix-non-sse2.patch'
+)
+md5sums=(
+ 'SKIP'
+ 'e7711b3c9f73a2f36fbf405663c05c9d'
+)
pkgver() {
cd ffts
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd ffts
+ # Patch to fix compilation on non-SSE2 machines
+ # Source: https://github.com/anthonix/ffts/pull/78
+ # (has no effect on SSE2 machines, so we can just always apply the patch)
+ git apply $srcdir/fix-non-sse2.patch
+}
+
build() {
mkdir -p ffts/build
cd ffts/build