summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAshwin Vishnu2018-06-18 14:33:21 +0200
committerAshwin Vishnu2018-06-18 14:33:21 +0200
commit68cde634137b57a70b8e3ad43d0091481b3d19ca (patch)
tree35a1ab1274bb177333d04eeb78cc82a279581faa /PKGBUILD
parentad231bb3b3999976f8195552750401633a5968f0 (diff)
downloadaur-68cde634137b57a70b8e3ad43d0091481b3d19ca.tar.gz
Version bump and add fPIC flag
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed5bd0e87c63..c389f012ccf5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Denis Gagnon <gagnon88 at gm41l dot com>
pkgname=fftw-mpi
-pkgver=3.3.7
-pkgrel=2
+pkgver=3.3.8
+pkgrel=1
pkgdesc="FFTW, compiled with MPI and OpenMP support: header files, static and shared libraries"
arch=('i686' 'x86_64')
license=('GPL2')
@@ -15,7 +15,7 @@ source=("http://www.fftw.org/fftw-${pkgver}.tar.gz")
provides=('fftw')
options=('staticlibs')
install=fftw.install
-sha1sums=('2ae980a8d44c161ce4a09c6e2d1c79243ecbabb2')
+sha1sums=('59831bd4b2705381ee395e54aa6e0069b10c3626')
# notes:
# http://www.fftw.org/fftw2_doc/fftw_6.html#SEC69
@@ -32,7 +32,7 @@ build() {
# use upstream default CFLAGS while keeping our -march/-mtune
- CFLAGS+=" -O3 -fomit-frame-pointer -malign-double -fstrict-aliasing -ffast-math"
+ CFLAGS+=" -O3 -fPIC -fomit-frame-pointer -malign-double -fstrict-aliasing -ffast-math"
CONFIGURE="./configure F77=gfortran --prefix=/usr \
--enable-shared --enable-threads --enable-mpi --enable-openmp"