summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDuckSoft2020-07-10 03:43:51 +0800
committerDuckSoft2020-07-10 03:43:51 +0800
commit627e474a49bbd71aced92c060e9d418e5b3ced06 (patch)
treea429d523040c5256926b7d203455b4731d3aa994 /PKGBUILD
parent426a54f273cde77af7800498fb63083477ea0463 (diff)
downloadaur-627e474a49bbd71aced92c060e9d418e5b3ced06.tar.gz
restructured and upgraded to 0.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 19 insertions, 37 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 44c6c85e738a..631301210b4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,34 @@
# Maintainer: Kevin Sanchez <kucashu@outlook.com>
# Maintainer: zhullyb <5435486@qq.com>
-# Maintainer: Ducksoft <realducksoft@gmail.com>
+# Maintainer: DuckSoft <realducksoft@gmail.com>
pkgname=fgit-go
-pkgver=0.5
+pkgver=0.6
pkgrel=1
pkgdesc="A tool to do git operation with fastgit easily"
-arch=('i686' 'x86_64' 'arm' 'arm64')
+arch=('x86_64')
url="https://github.com/fastgitorg/fgit-go"
license=('GPL3')
-depends=('git')
+depends=('git' 'glibc')
+makedepends=('upx')
provides=('fgit')
conflicts=('fgit')
+source=("$pkgname-$pkgver::git+$url#tag=$pkgver")
+sha512sums=('SKIP')
-source_i686=(
- "fgit::https://github.com/fastgitorg/fgit-go/releases/download/${pkgver}/fgit-linux-386"
-)
-source_x86_64=(
- "fgit::https://github.com/fastgitorg/fgit-go/releases/download/${pkgver}/fgit-linux-amd64"
-)
-source_aarch64=(
- "fgit::https://github.com/fastgitorg/fgit-go/releases/download/${pkgver}/fgit-linux-arm64"
-)
-source_armv6h=(
- "fgit::https://github.com/fastgitorg/fgit-go/releases/download/${pkgver}/fgit-linux-arm"
-)
-source_armv7h=(
- "fgit::https://github.com/fastgitorg/fgit-go/releases/download/${pkgver}/fgit-linux-arm"
-)
-
-md5sums_i686=(
- '620c2f28bc1c810375f519e6a26a3fe4'
-)
-md5sums_x86_64=(
- '62951732ddfb354907208e25500eb39b'
-)
-md5sums_aarch64=(
- '84e1360e1f68da7f9a2a98736d7c8aaa'
-)
-md5sums_armv6h=(
- 'eceaa6c0ea87588fe020c14e2d3f8308'
-)
-md5sums_armv7h=(
- 'eceaa6c0ea87588fe020c14e2d3f8308'
-)
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ CGO_ENABLED=1 GO111MODULE=off go build -v \
+ -buildmode=pie -trimpath \
+ -ldflags="-s -w -X main.version=`cat version` -X 'main.timestamp=`date +'%Y-%m-%d %H:%M:%S'`' -extldflags=-Wl,-z,now,-z,relro" \
+ -o fgit-go ./src/fgit.go
+}
package() {
- cd "$srcdir"
+ cd "$srcdir"/$pkgname-$pkgver
- install -Dm755 "fgit" "$pkgdir/usr/bin/fgit"
+ install -Dm755 -t "$pkgdir"/usr/bin/ ./fgit-go
+ install -Dm644 -t "$pkgdir"/usr/share/doc/fgit ./README.md
}
+