summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052023-12-21 15:26:54 +0800
committerzxp198210052023-12-21 15:26:54 +0800
commit3153275ed4e15ec1344247d97eb7a8f68f8c1506 (patch)
treef0e3c4f88d2068a8544c029cca7789c94b00128e /PKGBUILD
parent34e05998b89c10e1c7b7b116d4be6ef65ad997cd (diff)
downloadaur-3153275ed4e15ec1344247d97eb7a8f68f8c1506.tar.gz
fix errors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5638da9bd1a8..4ae020fb2bd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,42 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=ficus-bin
pkgver=0.2.1
-pkgrel=4
+_electronversion=13
+pkgrel=5
pkgdesc="A software for editing and managing markdown documents, developed by the gg=G team."
arch=('x86_64')
url="https://ficus.world/"
-_githuburl="https://github.com/Thysrael/Ficus"
+_ghurl="https://github.com/Thysrael/Ficus"
license=('MIT')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}" "${pkgname%-bin}-desktop")
depends=(
- 'electron13'
+ "electron${_electronversion}"
)
makedepends=(
'gendesk'
)
source=(
- "${pkgname%-bin}-${pkgver}.asar::${_githuburl}/releases/download/v${pkgver}/app.asar"
- "https://raw.githubusercontent.com/Thysrael/Ficus/v${pkgver}/LICENSE"
- "${pkgname%-bin}.png::https://raw.githubusercontent.com/Thysrael/Ficus/v${pkgver}/build/icon.png"
+ "${pkgname%-bin}-${pkgver}.asar::${_ghurl}/releases/download/v${pkgver}/app.asar"
+ "LICENSE-${pkgver}::https://raw.githubusercontent.com/Thysrael/Ficus/v${pkgver}/LICENSE"
+ "${pkgname%-bin}-${pkgver}.png::https://raw.githubusercontent.com/Thysrael/Ficus/v${pkgver}/build/icon.png"
"${pkgname%-bin}.sh"
)
sha256sums=('fb3a407722baa7b48b81db2753ae12f47799a3a434122d47db8b320c6c4ba993'
'062dfd6ae4c19f555ebbdba752598c98510837687393a38a3602b711890430d7'
'3c8344b3daac5c775a3bf38518e5eee024566d7ea0a3f72c543a7c7ae13f72ef'
- 'cf6a9a3f259d0760bd8ec9462c020294a11e930a1034956f8f8e9bb88aef128c')
+ '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
build() {
+ sed -e "s|@electronversion@|${_electronversion}|g" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|app.asar|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
gendesk -q -f -n --categories "Utility" --name "Ficus" --exec "${pkgname%-bin}"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/${pkgname%-bin}-${pkgver}.asar" "${pkgdir}/usr/lib/${pkgname%-bin}/app.asar"
- install -Dm644 "${srcdir}/${pkgname%-bin}.png" -t "${pkgdir}/usr/share/pixmaps"
+ install -Dm644 "${srcdir}/${pkgname%-bin}-${pkgver}.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
install -Dm644 "${srcdir}/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
- install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 "${srcdir}/LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
} \ No newline at end of file