summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKilian2017-02-11 12:51:36 +0100
committerKilian2017-02-11 12:51:36 +0100
commitbaa787915d6b90c8b76ecb956be70f86bc2740a4 (patch)
tree16d608d764e912e12d999efba42cf78d6ebb89cd /PKGBUILD
parent82895251db0d89ca5298661836b234b6b6ab8d2d (diff)
downloadaur-fifechan-git.tar.gz
Update conflict, provides and arch.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ba062310ca79..140d907b6146 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
# Maintainer: Kilian Köppchen <kiliankoeppchen at gmail dot com>
pkgname=fifechan-git
-pkgver=0.1.1.r20.gbcd9f57
+pkgver=0.1.4.r56.ga58eff3
pkgrel=1
pkgdesc="Fifechan is a C++ GUI library designed for
games. It comes with a standard set of 'widgets'."
-arch=(any)
+arch=('i686' 'x86_64')
url="http://fifengine.github.io/fifechan/"
license=('(L)GPL')
depends=('sdl2_image' 'allegro4' 'libgl' 'glut')
makedepends=('git' 'cmake' 'make')
source=("$pkgname"::'git+https://github.com/fifengine/fifechan.git')
md5sums=('SKIP')
+conflicts=("${pkgname/-git}")
+provides=("${pkgname/-git}")
pkgver() {
cd "$srcdir/$pkgname"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {