summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Cruz2019-06-23 16:45:10 -0300
committerRafael Cruz2019-06-23 16:45:10 -0300
commit4e8e50bc7e8fe54a70a04317ae2e112051cc0cf7 (patch)
treefcb3080470c6c1be0c0445fba61e96c4eced50ac /PKGBUILD
parentccf66e3a6667d1505e0ae8912e97c1ce95958807 (diff)
downloadaur-4e8e50bc7e8fe54a70a04317ae2e112051cc0cf7.tar.gz
Bugfix emulator config permissions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d925fd572f41..f294645c4ea3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=fightcade2
pkgver=2.0.12
-pkgrel=2
+pkgrel=3
pkgdesc='The best way to play your favorite retro games with or against any other player in the world.'
url='https://play.fightcade.com/'
arch=('any')
@@ -33,5 +33,9 @@ package() {
install -dm755 $pkgdir/opt/
install -Dm644 "$srcdir/Fightcade2/fc2-electron/resources/app/icon.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ msg "Copying files..."
rsync -r --chmod=755 $srcdir/Fightcade2/* $pkgdir/opt/$pkgname/
+ msg "Changing emulators configs permissions..."
+ chmod 777 "$pkgdir/opt/$pkgname/emulator/snes9x/fcadesnes9x.conf"
+ chown -R $USER $pkgdir/opt/$pkgname/emulator/fba/config/
}