summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTimo Wilken2019-11-30 13:37:33 +0000
committerTimo Wilken2019-11-30 13:37:33 +0000
commite0c0ab0b89a79b75af8b5b5a28a37625c2f6718b (patch)
tree71f5988f6e9737fcb933ffe679c9fed863e1c8d3 /PKGBUILD
downloadaur-e0c0ab0b89a79b75af8b5b5a28a37625c2f6718b.tar.gz
Add basic PKGBUILD.
Waiting on go-ahead and licence clarification from upstream author.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43fdb0540cf6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Timo Wilken <timo.21.wilken+aur@gmail.com>
+pkgname=fiji-plugin-multistackreg-bin
+pkgver=1.45
+pkgrel=1
+pkgdesc='MultiStackReg plugin for Fiji (JAR distribution)'
+arch=(any)
+url='http://bradbusse.net/sciencedownloads.html'
+license=('unknown')
+# Both fiji-bin and fiji-binary exist in the AUR, but fiji-bin seems more
+# up-to-date. They don't have a common provides= we could depend on here.
+depends=('fiji-bin')
+makedepends=()
+_jar_fname="MultiStackReg${pkgver}_.jar"
+source=("http://bradbusse.net/$_jar_fname")
+noextract=("$_jar_fname")
+sha256sums=('75ae1f6f8722779a7c293a0a855fe8b6d5b12db655e4168d7427d5c790e992bc')
+
+package() {
+ cd "$srcdir"
+ install -Ddm755 "$pkgdir/opt/fiji/plugins/"
+ install -m644 "$_jar_fname" "$pkgdir/opt/fiji/plugins/"
+}