summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndy_Vetrov2019-02-14 20:35:29 +0300
committerAndy_Vetrov2019-02-14 20:35:29 +0300
commit32b20b29547885f5961446ab6e3780c027d916ab (patch)
treeec85c9783412bc10229a11527d961b949eda965a /PKGBUILD
parenta9e139149c52a6aa57e1bd3ee2c198b2c29a2e99 (diff)
downloadaur-32b20b29547885f5961446ab6e3780c027d916ab.tar.gz
Pick package up2date
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 23 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 42fcc6d0c7aa..389c7ff03e05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
-# $Id$
# Maintainer: Kresimir Pripuzic <kpripuzic@gmail.com>
+# https://aur.archlinux.org/packages/file-roller-tmp/
pkgname=file-roller-tmp
-pkgver=3.24.1
+pkgver=3.30.1
pkgrel=1
-pkgdesc="The file-roller with an additional patch to put temporary files in /tmp instead of ~/.cache (and thus to reduce the amount of writes to SSDs)."
-arch=(i686 x86_64)
+pkgdesc="Create and modify archives. SSD-friendly version (stores temporary files in /tmp)."
+url="https://wiki.gnome.org/Apps/FileRoller"
+arch=(x86_64)
license=(GPL)
-depends=(gtk3 dconf libarchive file json-glib libnotify zip unzip)
-makedepends=(intltool itstool docbook-xsl gnome-common git libnautilus-extension)
+provides=("file-roller=$pkgver")
+conflicts=('file-roller')
+replaces=('file-roller')
+depends=('gtk3' 'dconf' 'libarchive' 'file' 'json-glib' 'libnotify' 'zip' 'unzip')
+makedepends=('yelp-tools' 'git' 'libnautilus-extension' 'meson' 'appstream-glib')
optdepends=('p7zip: 7z, arj, exe and encrypted zip files support'
'unrar: better RAR archive support'
'unace: ACE archive support'
'lrzip: lrzip archive support')
-groups=(gnome-extra)
-provides=('file-roller')
-conflicts=('file-roller')
-_commit=e6ef6fa43a6d5d6e1509f122a206870adc113563 # tags/3.24.1^0
-source=("git+https://git.gnome.org/browse/file-roller#commit=$_commit"
- tmp-as-temp.patch)
-sha256sums=('SKIP'
- '753c6ee41772677b115f4178fe6384c21d8aa5d489a6074f659d5305736acf57')
+groups=(gnome)
+_commit=7962fbaf86db77ec6c0713491920341487be1681 # tags/3.30.1^0
+source=("git+https://gitlab.gnome.org/GNOME/file-roller.git#commit=$_commit"
+ 'tmp-as-temp.patch')
+sha256sums=('SKIP' 'SKIP')
pkgver() {
cd ${pkgname:0:11}
@@ -28,8 +29,7 @@ pkgver() {
}
prepare() {
- cd ${pkgname:0:11}
- NOCONFIGURE=1 ./autogen.sh
+ cd ${pkgname:0:11}
#patch
cd $srcdir/${pkgname:0:11}
@@ -37,14 +37,14 @@ prepare() {
}
build() {
- cd ${pkgname:0:11}
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --libexecdir=/usr/lib/$pkgname --disable-static --disable-schemas-compile
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
+ arch-meson ${pkgname:0:11} build
+ ninja -C build
+}
+
+check() {
+ meson test -C build
}
package() {
- cd ${pkgname:0:11}
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install -C build
}